1

This may well be due to a migration from SharePoint 2010 to 2013 that might be causing this weird search issue I am having, but I am noticing that I cannot get search working using the InPlaceSearch textbox that resides on the top of a lists webpart.

I have tried the following: Enabling Search Radio Button in the Advanced Tab Turn off the Approval in the Versioning section in the settings area (was never on, actually)

Essentially followed most of all the suggestions in google so far :)

Now, the thing I have to ask, is that when I empty the search field and the InPlaceSearchQuery becomes blank, all the results in the list will pop out again. Is it possible that the InPlaceSearchQuery is looking up a very specific index (or mapping) that all I have to do is include the column in that mapping within Central Admin and that will fix the issue?

Would anybody have, by any chance, a copy of what these settings might be (for the Title column perhaps) that I can cross reference to see if our migrated mappings/settings are clobbering what the OOTB settings should be?

As a note I have tried the suggestions on this: SharePoint 2013: "Find an Item" search box does not return results

So I guess this question is somewhat related.

  • 1
    Ahhh okay, sorry it was indeed the AAM mismatch. So the content source config for the crawler must need to match whatever the Default address is under the Alternate Access Mapping. – Wonderboy Nov 6 '15 at 1:42
1

It was indeed the AAM mismatch to be the culprit. So the content source config for the crawler must need to match whatever the Default address is under the Alternate Access Mapping.

So the steps to resolve this problem is to: Hop into Central Admin Click on Application Management

Configure alternate access mappings (under Web Applications)

Find out what the address is under the Default Zone, copy it.

Pop back into Central Administration -> Manage Service Applications -> Search Services -> Content Sources

Click on the Source responsible for your Sharepoint (it's probably called Local SharePoint Sites): make sure Start Addresses contains the exact same address as the one you copied up top.

Leave the sps3 entry there, that's the People Profile crawler you'd want that there.

That's it for me, results are now showing up on the InPlaceSearch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.