0

I found solution to this problem.

The issue was due to the self signed certificate which I was using for the SharePoint site. When I used the certificate issued particularly to my SharePoint site it worked without any errors.

i saw your solution for the below thread https://social.msdn.microsoft.com/Forums/expression/en-US/1a32b892-08c6-43e7-b988-667fc6ef1aa3/https-sharepoint-site-with-https-provider-hosted-app-the-remote-certificate-is-invalid-according?forum=sharepointdevelopment

Can you please explain more details about the solution you provided because i am getting same error

0

In most of cases the issue is, if you are using a self-signed certificate that has not been placed in the Trusted Root Certification Authorities Store or ‘SharePoint root authority’ certificate is missing from the ‘Trusted Root Certificate Authorities’ container.

Once you add the cert in the store or via central admin of sharepoint, then it will fixed.

read more here: http://blog.gavin-adams.com/2015/07/01/sharepoint-2013-could-not-establish-trust-relationship-for-the-ssltls-secure-channel-with-authority/

  • New-SPTrustedRootAuthority -Name "AppName" -Certificate $certificate if you run the above command automatically your certificate placed in central admin -Manage Trust it is fine for my case. and i followed below steps to validate my apps jeremythake.com/2013/12/… but still getting same error if i give Tokenhelper.TrustAllCertificate() in my page load its working . – Anand Nov 9 '15 at 15:50
  • My Environment has 2 WFE servers 1 App Server 1 DB Server now VS2012 is installed in 1 WFE server and i followed all my steps in WFE server where VS 2012 installed.and copied my Certificates in All other Servers as well but still getting same error.if i handle the certificate validation error in server side its working.but what steps i am missing probelm with "mysiteurl"//_vti_bin/client.svc webservice response only.if certificate validation fails it does not work – Anand Nov 9 '15 at 15:58
  • lennytech.wordpress.com/2013/06/18/… i checked this url also it says certificate already in trusted root authrority. guybachar.wordpress.com/2014/05/28/… my question is Central admin my certificate avaialble and local trust Root Authority also contains my certificate and followed the validations steps but still getting same error. can you help me to solve this issue with any other approach. – Anand Nov 11 '15 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.