0

In my sp 2013, I am trying to do a rest api and get security trimmed results, when I try my url

_spPageContextInfo.siteAbsoluteUrl + /_api/web/lists/getbytitle('Navigation')/items?$select=Comments,effectivebasepermissions&$filter=effectivebasepermissions/high%20gt%2032&$top=1000

I get back

<m:error><m:code>-2147024809, System.ArgumentException</m:code><m:message xml:lang="en-US">Column 'effectivebasepermissions' does not exist. It may have been deleted by another user.  /Lists/Navigation</m:message></m:error>

Does anyone know whats wrong?

  • Results should be security trimmed for you already in all of the web services, REST or SOAP, you don't need to ask for it. – Eric Alexander Nov 4 '15 at 15:01
  • But here chrisstahl.wordpress.com/2014/06/30/… it says The result from a REST query are not security trimmed so if you want to display only the sites for which the users has access to... – omega Nov 4 '15 at 15:03
  • Theres also this social.msdn.microsoft.com/Forums/sharepoint/en-US/… – omega Nov 4 '15 at 15:05
  • 1
    Trust me; if REST results were not security trimmed CNN, Fox and Saturday Night Live would report nothing else. – Danny '365CSI' Engelman Nov 4 '15 at 15:06
  • Does effectivebasepermissions/high exist? Make sure it is the internal name. Another thing / is used in lookup column. If effectivebasepermissions is a lookup column, then you must expand it. – Atish Dipongkor - MVP Nov 4 '15 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.