1

I am using the URL http://office.microsoft.com/en-us/sharepoint-designer-help/create-a-secondary-workflow-HA010237656.aspx

I have a Primary Workflow on a Document library, that works just fine... the secondary workflow is associated with the Tasks list, and the secondary workflow is not working... The task is created by the primary workflow, but on creation its not firing the secondary workflow...

Any ideas?

  • Can you check and see if the permissions for the two lists are the same? Thanks! – Lori Jul 13 '11 at 18:44
  • 2
    Did you set the secondary workflow to start automatically when an item is added to the list? – Laurie Jul 13 '11 at 19:21
  • Yes permissions are correct, and yes I set the secondary workflow to start automatically when an item is created, also I kept it to be manually started... but none works... – Arsalan Adam Khatri Jul 15 '11 at 11:02
0

If the secondary workflow is triggered by a process that is running under the system account, e.g. An item update after some kind of async process, then the workflow will not trigger. This is a security feature added in wss 3 sp1.

  • I dont believe this was the problem, it worked perfectly fine when I logged in with a different user other than System Account, to hack with this security feature :D – Arsalan Adam Khatri Jul 15 '11 at 11:43
  • What is difference between permissions of System Account and the other user you used? – Kamalpreet Oct 23 '15 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.