1

In this case it's (of course) the User Profile Service Application. How can I force it to stop? I've tried:

stsadm -o provisionservice -action stop -servicetype "M
icrosoft.Office.Server.Administration.UserProfileService, Microsoft.Office.Serve
r.UserProfiles, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e942
9c"

But alas, it did not work (completed successfully but didn't stop the service). My main goal is to delete the application.

6
  • Have you tried to delete it from the UI or Powershell ( Remove-SPServiceApplication )? Jul 13, 2011 at 17:58
  • Yes I've successfully remove and re-created it. After it is freshly created, the Synchronization service is still in "Stopping" mode. Looking for a way to manually change that because I don't think it really is in that state.
    – Josh M.
    Jul 13, 2011 at 18:37
  • Did you choose the option to delete the database on both the proxy and the main application? In my experience, those steps may be necessary as part of the deletion to recreate it correctly.
    – Tom Resing
    Jul 14, 2011 at 20:42
  • I did check the delete database option, to no avail.
    – Josh M.
    Jul 14, 2011 at 21:18
  • Did you ever solve this issue, I´m stuck with the same problem.
    – user15181
    Feb 27, 2013 at 8:14

3 Answers 3

3

Something may not be configured correctly, possibly the permissions.

I recommend some reading on the User Profile Service. It is a very valuable service but a little tricky to set up. So tricky, in fact, that Spencer Harbar has written an entire guide to setting up the User Profile Service correctly.

I also recommend the Stuck on Starting FAQ by the same author.

1
  • It's certainly NOT configured properly, that's why I'm trying to delete it! So I can properly follow the instructions at the blog you linked, which I'm already on.
    – Josh M.
    Jul 13, 2011 at 15:13
0

Since it is stuck on stopping, check the services that are mentioned using services.msc and stop those services and see if that helps it actually stop the SharePoint service.

1
  • It doesn't. I've also rebooted.
    – Josh M.
    Jul 13, 2011 at 16:17
-1

I have the same question but no answers, unfortunately. Here is what I did to arrive at this condition:

A User Profile Service application wasn't synching correctly, so I decided to create another one, leaving the existing one intact.

I created another User Profile Service Application, that is synching well. Since it is now working, I decide to delete the old one.

When I do so, its get stuck in the stopping state. The state is persistent through a reboot.

Is there a way to force remove it?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.