0

I moved my SQL server from the server hosting Sharepoint to another server. Since then, I've had db permission errors (ex.

Insufficient SQL database permissions for user 'Name: domain\sp2013_farm SID: S-1-5-21-3144544779-1869488410-2151655755-1609 ImpersonationLevel: Impersonation' in database 'SharePoint_AdminContent_7b914aee-c2ae-4651-8760-ff3b6b27d222' on SQL Server instance 'infostore\infostore'. Additional error information from SQL Server is included below.

The SELECT permission was denied on the object 'Sec_SiteGroupsView', database 'SharePoint_AdminContent_7b914aee-c2ae-4651-8760-ff3b6b27d222', schema 'dbo'.`

I've verified that my farm account has db_owner access to that db, so I'm not sure what else to check.

This error happens when I try to open site settings http://centraladministration/_layouts/15/people.aspx. I'm getting similar permissions errors when trying to access search crawl settings. http://centraladministration/_admin/search/crawlhealthreports.aspx & http://centraladministration/_admin/search/queryhealthreports.aspx

0

Your farm account is not a SQL Login account.

So you dont need to use login and password, just specify the database server and then click OK.

  • where to specify the database server? I added the farm account as a sql login account? – Trevor Newhook Oct 30 '15 at 15:53
0

I ended up just recreating the SSA.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.