1

I have a library in SharePoint storing some instructions documents. For clarity and ease of use, I have posted links to the appropriate documents on a wiki page (so the actual library is not visible). When opening the documents from the links on the wiki page, you get a bar across the bottom of the screen with one button "open the document" and when you click that and enter the document, you get the yellow bar across the top of the document "READ ONLY - we opened this workbook read-only from the server" with an "Edit workbook" button. When I go into the document from the library itself, I get the message box with radio button options of opening in read only or edit mode, and not the "open document" at the bottom of the screen or the yellow bar in the document itself.

I am just wanting to understand why this discrepancy exists.

1

When you open a document through the SharePoint UI with IE, it is being opened via an ActiveX control:

<A onclick="return DispEx(this,event,'TRUE','FALSE','FALSE','SharePoint.OpenDocuments.3','1','SharePoint.OpenDocuments','','','','18','0','0','0x7fffffffffffffff')" onfocus=OnLink(this) href="/sites/MySite/Library/some.docx">some</A> 

When you link directly to your document from your Wiki, IE will either use the Office Document Cache Handler (urlredir.dll -- URLRedirection.URLRedirectionBHO), if installed and enabled, or use the Explorer file associations to figure out how to load the document.

0

This has to do with the library settings. Go into the Advanced settings section and you will find different options to open the document. Change the settings to Open in the client application in this case and it should behave the same everywhere.

enter image description here

1
  • Thank you for the response, however I have done this already. The library needs to be opened in the client application due to some limiting factors (sheet protection, macros, etc.). It still opens differently depending on how I go into it (through the link or through the library). – ktielens Nov 2 '15 at 21:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.