1

One of my list in SharePoint 2013 on premise is showing warning 4838 items (list view threshold is 5000), so Indexed one of the column "Code" (single line of text) and created 5 views, with "Code" in the filter in each view "Code (Indexed)"

Even after changing the "All Items" view with filter, I am still having the warning message, I am not sure how to resolve this issue.

1

You will still have the warning message there even though you have indexed a column. As long as you have indexed all of the columns you would potentially need to filter on then you should be fine.

The warning is there to let you know that you will soon hit the threshold and that if you want to filter on any fields they need to be indexed before you hit that threshold. I would say you and the warning worked exactly as intended.

If you really wanted to get rid of the warning you could raise the list view threshold, but it's not generally recommended. In your case it doesn't really seem needed either.

EDIT:

Here's some more documentation on the list view threshold and a quote pulled directly from the article.

Manage lists and libraries with many items

To give you time to make alternative plans, SharePoint 2010 warns you on the List Settings page when your list has exceeded 3,000 items. The warning contains a help link to this topic.

  • I have created 5 views filtered with the indexed column, so each view is about 1200 items in it, but still I am seeing the warning, is that fine? – Rao Oct 27 '15 at 14:19
  • Yep, the warning isn't specifying your view. It's a warning to let you know that the list itself is about to hit the threshold. – Jordan Oct 27 '15 at 14:22
  • Added documentation link to answer. – Jordan Oct 27 '15 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.