1

I had enabled SharePoint server publishing feature in my site, which is a site collection as well. But unfortunately the Pages library is not getting created and i am unable to create any publishing pages.

Is there a way to solve this. I tried deactivating and activating again from the site settings, using stsadm commands.

Or can we create the Pages Library Manually?

EDIT

When I checked the site with the SharePoint Designer, The lists and libraries tab is showing there are no items to show.

But in All Files a folder is listed with the name "pages" and with Title as "Workspace Pages"

On Right clicking on the item and selecting properties it shows an error window saying

The object used for selected operation could not be found. The item may have been removed or deleted.

The same message appears for other lists that are available in the SharePoint website.

EDIT 2

The site was created using "Decision meeting workspace". and hence had the hidden "pages" library.
Removed library named "Pages" and again tried to reactivate the features .

The feature activation shows no error.
There are no entries of error in the ULS logs for feature activation .

On Deactivating , error page loads up with following

"The site is not Valid. The "Pages" document library is missing."

1

Old thread but adding my problems and solutions for others:

  1. We had a solution that deployed a folder named "Paginas" ("Pages" in PT-BR), and that is the same name used by the Pages Library in PT-BR SharePoint. So watch out for a folder or library named in your language if you are not using EN-* SharePoint.
  2. The same holds for the "Images" library, but a little bit worse: the library created by Publishing Features uses "PublishingImages" as its folder name, but it's titled "Images" ("Imagens" in PT-BR), an the solution also created a folder with that name.
  3. Even after renaming the folders, deactivating/reactivating Publishing Features (site/site coll levels) didn't create the Pages Library. I then ran some PS taken from another similar question to force disabling and re-enabling of all Publishing Features:

SharePoint Server:

Disable-SPFeature –identity 'publishingSite' -URL http://server/sites/site -force
Disable-SPFeature –identity 'PublishingResources' -URL http://server/sites/site -force
Disable-SPFeature –identity 'Publishing' -URL http://server/sites/site -force
Disable-SPFeature –identity 'PublishingLayouts' -URL http://server/sites/site -force
Disable-SPFeature –identity 'publishingweb' -URL http://server/sites/site -force

Enable-SPFeature –identity 'publishingSite' -URL http://server/sites/site -force
Enable-SPFeature –identity 'PublishingResources' -URL http://server/sites/site -force
Enable-SPFeature –identity 'Publishing' -URL http://server/sites/site -force
Enable-SPFeature –identity 'PublishingLayouts' -URL http://server/sites/site -force
Enable-SPFeature –identity 'publishingweb' -URL http://server/sites/site -force

SharePoint Online/PnP-PowerShell:

Disable-SPOFeature –Identity "F6924D36-2FA8-4f0b-B16D-06B7250180FA" -Scope Site
Disable-SPOFeature –Identity "AEBC918D-B20F-4a11-A1DB-9ED84D79C87E" -Scope Site
Disable-SPOFeature –Identity "22A9EF51-737B-4ff2-9346-694633FE4416" -Scope Web
Disable-SPOFeature –Identity "D3F51BE2-38A8-4e44-BA84-940D35BE1566" -Scope Site
Disable-SPOFeature –Identity "94C94CA6-B32F-4da9-A9E3-1F3D343D7ECB" -Scope Web

Enable-SPOFeature –Identity "F6924D36-2FA8-4f0b-B16D-06B7250180FA" -Scope Site
Enable-SPOFeature –Identity "AEBC918D-B20F-4a11-A1DB-9ED84D79C87E" -Scope Site
Enable-SPOFeature –Identity "22A9EF51-737B-4ff2-9346-694633FE4416" -Scope Web
Enable-SPOFeature –Identity "D3F51BE2-38A8-4e44-BA84-940D35BE1566" -Scope Site
Enable-SPOFeature –Identity "94C94CA6-B32F-4da9-A9E3-1F3D343D7ECB" -Scope Web

(OBS1: if you have already disabled the Publishing Features, some of the "Diasble-SPFeature" commands may fail with the message "Disable-SPFeature : Feature '...' is not activated at this scope". But that's ok.)

(OBS2: Some features may apply to the site collection level, some to site level, but as I was working on a root level web everyting went ok. That's one thing to check out - feature scope - if some Enable-SPFeature command fails.)

After disabling/re-enabling the features with the above PowerShell the Pages Library - and Images, and Documents, and Site Collection Documents, and Site Collection Images libraries - all were created successfuly.

0

There are two features to be activated.

  1. Site Settings -> Site collection features -> SharePoint Server Publishing Infrastructure
  2. Site Settings -> Manage site features -> SharePoint Server Publishing,

Have you activated both?

Source

  • Yes i have , that doesn't seem to solve the problem. – mallu coder Oct 27 '15 at 10:42
  • can you open the site collection in sharepoint designer and check if Pages library is visible there. – Garima Oct 27 '15 at 10:51
  • Yes it is there . i have updated in the question now. – mallu coder Oct 27 '15 at 11:18
  • great! take necessary backup and delete that folder. Deactivate both the features I mentioned above and activate them again. This should do the trick. – Garima Oct 28 '15 at 9:04
  • Thats been tried. Didnt work either. – mallu coder Oct 28 '15 at 9:23
0

Try deleting the pages folder that aleady exists using sharepoint desinger or rename that folder. Then deactivating and reactivating the publishing features should create the pages library. If you look in the ULS logs - there you may be able to see an error saying that a folder named "Pages" already exists. Hence it fails to create a new Pages library that you need.

  • Tried and failed. – mallu coder Oct 28 '15 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.