0

I am having trouble with a helpdesk we are using. It had been set for internal staff to use and so when they raised a ticket, it remembered who they were and could then send email updates out nice and easily using that info. Never had any problems with it failing to send.

However, we are now looking into allowing another company access to report the issues to us. So far, we have made one generic account which they will all have access too (there are around 3-400 staff, it is not seen as viable to give them all accounts). I have also added another column, "Contact", where they can enter their email address.

The email is sent out by a Workflow anytime the ticket is updated. I have now changed the recipient to "Current Item:Contact" but the emails are not coming through. The Workflow says it completes, but there is a message "The e-mail message cannot be sent. Make sure the outgoing e-mail settings for the server are configured correctly"

I have seen suggestions to add a pause first, but this makes no difference (its the only workflow to run on ticket update anyway.

Any other ideas would be greatly appreciated. It worked fine for domain users, just not sending for addresses added to the new field.

0

This may be due to not having anonymous access enabled on the receive connector in your Exchange server.

  • I've just checked through all my SMTP settings using this guide technet.microsoft.com/en-gb/library/cc288949(v=office.14).aspx Everything looks to be set up correctly and anonymous access is definitely checked. – Jon Duxbury Oct 23 '15 at 14:23
  • I had a smiliar issue - to solve that I had to allow anonymous access at the exchange server level. Have a look at this article. sharepointgeorge.com/2010/… – HarryB Oct 23 '15 at 14:31
  • Went through that link which was nice and easy to follow, but still no luck. Its not going to cause an issue that SharePoint and Exchange are both running on the same server is it? Any time it asks for an IP address I'm just entering the internal address of the server, 192.168.100.2 – Jon Duxbury Oct 23 '15 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.