3

I have a publishing web. When I try to create add new page I am getting the error

Invalid field name. {9da97a8a-1da5-4a77-98d3-4bc10456e700} /Pages"

This is pointing to Pages Library. Please refer the log below:


Exception A critical error occurred while creating a PublishingPage through PublishingWeb.AddPublishingPage(string, PageLayout, SPFolder). System.ArgumentException: Invalid field name. {9da97a8a-1da5-4a77-98d3-4bc10456e700} /Pages at Microsoft.SharePoint.SPFieldCollection.GetFieldById(Guid fieldId, Boolean bThrowException) at Microsoft.SharePoint.SPListItem.set_Item(Guid fieldId, Object value) at Microsoft.SharePoint.Publishing.CommonUtilities.SetTextFieldValue(SPListItem item, Guid fieldId, String value) at Microsoft.SharePoint.Publishing.PublishingPage.set_Description(String value) at Microsoft.SharePoint.Publishing.PublishingWeb.<>c__DisplayClass27.b__22() at Microsoft.Office.Server.Diagnostics.FirstChanceHandler.ExceptionFilter(Boolean fRethrowExceptio... ae573a9d-2c08-7098-d325-99784aaa7766 Exception ...n, TryBlock tryBlock, FilterBlock filter, CatchBlock catchBlock, FinallyBlock finallyBlock) StackTrace: at Microsoft.Office.Server.Native.dll: (sig=d5e0e3f0-a250-4276-9f13-b1e5ec5f671c|2|microsoft.office.server.native.pdb, offset=131CE) at Microsoft.Office.Server.Native.dll: (offset=21C85) ae573a9d-2c08-7098-d325-99784aaa7766 Monitorable Watson bucket parameters: SharePoint Server 2013, ULSException14, 81eed5e0 "web content management", 0f001144 "15.0.4420.0", 1f65804a "microsoft.sharepoint", 0f001151 "15.0.4433.0", 508f9059 "tue oct 30 14:01:21 2012", 00007667 "00007667", 000000ae "000000ae", 44395864 "argumentexception", 61357936 "a5y6" ae573a9d-2c08-7098-d325-99784aaa7766 Unexpected A critical error occurred while creating PublishingPage 'asdfasd.aspx' through PublishingWeb.AddPublishingPage(string, PageLayout, SPFolder). Exception Invalid field name. {9da97a8a-1da5-4a77-98d3-4bc10456e700} /Pages ae573a9d-2c08-7098-d325-99784aaa7766 Warning A database error occurred.

  • I was able to resolve this issue. Please follow the steps: 1. Goto Document Library Settings. In my it was Pages Library. 2. Under Content Types you will find the list of content types associated with your library. 3. In my case there were 3 custom content types and 3 system content types 4. Goto first content type lets say Content type1 5. Under settings "Delete this content type" say yes to prompt. [this actually doesn't delete instead removes the content type from library. So don't worry to delete it] – Vikas Sharma Oct 26 '15 at 9:25
  • 6. If this content type is being used SharePoint in different places, It will not allow you to delete. it will tell you that content type is still in use. 7. Repeat the step 4 and 5 for all the content types 8. I noticed the missing field "Comments" got added on my Content Type 4. 9. Later I tried to add the page. I was able to add the page. Note: You might need to set the default PageLayout again. From Site Setting --> Master Pages and Page Layout section – Vikas Sharma Oct 26 '15 at 9:26
  • Super! Put that as an answer instead of a comment and you'll help others (and possibly also be awarded reputation points, if others find your answer useful)! – Benny Skogberg Oct 26 '15 at 9:28
3

I was able to resolve this issue. Please follow the steps:

1. Goto Document Library Settings. In my case it was Pages Library.
2. Under Content Types you will find the list of content types associated with your library.
3. In my case there were 3 custom content types and 3 system content types
4. Goto first content type lets say Content Type-1
5. Under settings "Delete this content type" say yes to prompt. [this actually doesn't delete instead removes the content type from
library. So don't worry to delete it]
6. If this content type is being used by SharePoint in different places, It will not allow you to delete.  it will tell you that
content type is still in use.
7. Repeat the step 4 and 5 for all the content types
8. I noticed the missing field "Comments" got added on my Content Type 4.
9. Later I tried to add the page. I was able to add the page.

Note: You might need to set the default PageLayout again. From Site Setting --> Master Pages and Page Layout section

0

I ve solved this problem by adding "Page" to content types in my library:

enter image description here

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.