1

I created SharePoint 2013 Empty Project. I added Application Page, and I used webservice in page. When I running the page I get this error:

enter image description here

I added my ULS log. How can I solve this?

UserAgent not available, file operations may not be optimized. at Microsoft.SharePoint.SPFileStreamManager.CreateCobaltStreamContainer(SPFileStreamStore spfs, ILockBytes ilb, Boolean copyOnFirstWrite, Boolean disposeIlb) at Microsoft.SharePoint.SPFileStreamManager.SetInputLockBytes(SPFileInfo& fileInfo, SqlSession session, PrefetchResult prefetchResult) at Microsoft.SharePoint.CoordinatedStreamBuffer.SPCoordinatedStreamBufferFactory.CreateFromDocumentRowset(Guid databaseId, SqlSession session, SPFileStreamManager spfstm, Object[] metadataRow, SPRowset contentRowset, SPDocumentBindRequest& dbreq, SPDocumentBindResults& dbres) at Microsoft.SharePoint.SPSqlClient.GetDocumentContentRow(Int32 rowOrd, Object ospFileStmMgr, SPDocumentBindRequest& dbreq, SPDocumentBindResults& dbres... d21c3a9d-8383-f0d1-7044-7c37d99ee4b0

UserProfileProperty_WCFLogging::Begin ProfilePropertyServiceClient.ExecuteOnChannel

Application error when access /_layouts/15/test/entegrasyon.aspx, Error=Object reference not set to an instance of an object. at test.Layouts.test.Entegrasyon.Page_Load(Object sender, EventArgs e)

...(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) at System.Web.UI.Page.ProcessRequest()

UserProfileProperty_WCFLogging :: End UserProfileApplication.GetProperties

Cleanup of Orphan Systems in server servername NerioCluster : Got Lease until 10/22/2015 13:00:39 for net.tcp://servername/630210/AdminComponent1/Services/InvokerService

1

There is a null object being accessed in your Page_Load method according the logs below:

Debug the Page_Load method by setting a breakpoint at the begining of the method. Without looking at the actual code in the Page_Load method it is not clear what your code is doing in the method.

Application error when access /_layouts/15/test/entegrasyon.aspx, Error=Object reference not set to an instance of an object. at test.Layouts.test.Entegrasyon.Page_Load(Object sender, EventArgs e)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.