1

My colleague's STS site suddenly showed this error when she tried to add New Item.

Unable to display this Web Part. To troubleshoot the problem, open this Web page in a Microsoft SharePoint Foundation-compatible HTML editor such as Microsoft SharePoint Designer. If the problem persists, contact your Web server administrator.

Correlation ID: Some GUID

It has worked until today for a month and I haven't made any change in the source.

I have checked on the internet and found the following solution on this forum: Unable to display this Web Part - using data form web part with grouping and large list

My source looked similar to this, so I changed the   to  . However the error still came up and couldn't open the New Item.

I have no clue to this error because it suddenly happened. (I am not the one who customised the source.)

  • Did you check the Logs using the Correlation GUID to get more Information about the Problem eg which Webpart causes the error? – Leopold Lerch Oct 20 '15 at 12:11
  • Hi Leopold, thanks for your comment! I don't think I checked the logs. Can you tell me where to find them? – Tomomi Oct 21 '15 at 0:27
0

make sure the resources the webpart is using has the right permissions.

For Eg. The webpart may be accessing data from site assets/style library etc. So check the permissions of user on the corresponding library from webpart.

If the user doesn't have the necessary permission then you won't be able to see the web part n SP will give you error "Unable to display this Web Part"

It Worked for me. Check!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.