2

I created a custom master page (based on "seattle.master" that we currently use) and uploaded it to the Master Page Gallery on our site collection. However, now I am at a loss on how to get the site collection to use my custom master page instead of the default "seattle.master" one. We are using SPF 2013, so I do not have (and cannot seem to enable) the "Master page" link under the "Look and Feel" section of Site Settings. How does one go about this in SPF 2013?

2

To change the master page in SPF 2013:

  1. Install SharePoint Designer (MSFT link current as of this post: http://www.microsoft.com/en-us/download/details.aspx?id=35491)
  2. On the machine you have installed Designer on, browse to the SP site, and on the "Page" tab, select "Edit Page > Edit in SharePoint Designer"
  3. SP Designer launches, and connects to the site.
  4. On the left nav bar in Designer, click on "Master Pages"
  5. Right-click on the master page you'd like to make the default for the site.
  6. From the resulting context menu, choose "Set as Default Master Page".
0

You can change the master page using SharePoint Designer or publishing feature needs to be activated to get the master page option under look and feel but not sure if you get that in Foundation version. So use SharePoint Designer(easiest option) or powershell or CSOM.

  • My understanding (from reading stuff on Google) is that you cannot enable "SharePoint Server Publishing" on SPF 2013... In fact there's no "Site Collection Administration" subsection in Site Settings at all (just "Site Administration" and "Site Actions", neither of which have a "Site Collection Features" link) – Will Dennis Oct 16 '15 at 15:15
  • Correct. You need to site collection admin to see the Site Collection Administration section. As I said you should be still be able to change the master page using other option as suggested in my answer – HarryB Oct 16 '15 at 15:17
  • SharePoint Designer 2013 will let you do it. Publishing won't be available in Foundation – Steven Mulkerrins Oct 16 '15 at 15:23
  • Thanks @HarryB - that was part of the problem (I was not in fact set as a site collection admin for the site collection in question...) – Will Dennis Oct 16 '15 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.