1

I have a work flow:

https://i.stack.imgur.com/l2ctA.jpg

that will only start when I make a change in a list item.

The way it is suppose to work is when any user updates/changes the column "Resolved by" The workflow runs it copies the current item to a new list based on the year and then deletes the current item.

All this is being done in the data sheet view. When I update the column it works perfect. I am the site admin and have full control etc.

But when anyone else updates the column the workflow never starts even though they have contribute and approve permissions.

Any ideas on what could be happening?

Thanks,

Edit: I'm on SharePoint 2010 FYI.

2
  • If another user tries to start the workflow manually on an item, does it run correctly?
    – Erin L
    Oct 16, 2015 at 15:19
  • I actually figured it out now and I feel stupid. I didnt have contribute permissions setup in the End destination list so you couldnt move the line item.
    – TPLEE
    Oct 16, 2015 at 17:33

1 Answer 1

0

What kind of permissions do they have on a site collection/subsite level? Do you have broken inheritance for the list or is it inheriting from the site?

Please check: Not enough permissions to start workflow with read permissions and https://technet.microsoft.com/en-us/library/ee428324%28v=office.14%29.aspx?f=255&MSPPError=-2147217396

and try assigning permissions on a site level.

2
  • 1
    I actually figured it out now and I feel stupid. I didnt have contribute permissions setup in the End destination list so you couldnt move the line item.
    – TPLEE
    Oct 16, 2015 at 17:33
  • Glad it's fixed :)
    – grisha
    Oct 16, 2015 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.