1

First of all, I'm using Infopath 2013 in polish version, so the names of functions may be different.

Yesterday, I got an old Infopath 2013 file, which was migrated from 2010(at least collegue I got it from says so), including code but not documentation, which we are using in internal SPS. I was supposed to add one field and move on.

However, I can't even preview the file(file is unchanged). After some Googling I got some hints, that it may be due to file being copied&pasted and I follow tutorial on how to fix it - but to no effect.

There is an error message, yes. As you can see on image below, not even a little bit helpful. This error was sometimes related to code, but after setting breakpoint in code, nothing happens, as if it was never hit. Not even InternalStartup().

The error I get

I tried moving everything to a folder with shorter path, publishing using settings[same(probably?) error as with preview], unlinking/removing code, checking the code, publishing elsewhere(no error, still cannot preview).

Did it happen anyone else, and what can I do to fix it?

1

Oh well...

Just a minute ago I stumbled into this: https://social.msdn.microsoft.com/Forums/en-US/abd2166b-a9ad-487e-bf83-8bb1d44ae7e5/error-infopath-cannot-open-the-selected-form-in-preview-mode-infopath-2007?forum=sharepointcustomizationlegacy

Which had solved my issue. I'm posting what was issue, if link would broke someday.

I found out that the URL in Tools-->Form Options-->Preview-->Domain was wrong/missing.

I've added the URL and - bam - it worked fine again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.