I've installed a fresh copy of Windows Server 2008 R2 into a virtual machine, using VirtualBox.

Now I'm trying to install the prerequisites for Sharepoint, using the "Microsoft Sharepoint Products and Technologies 2010 Preparation Tool".

Every time I run this tool, after some processing, I keep getting the following error:

The tool was unable to install Microsoft "Geneva" Framework Runtime

  • Application Server Role, Web Server (IIS) Role: configured successfully
  • Microsoft SQL Server 2008 Native Client: installed successfully
  • Microsoft "Geneva" Framework Runtime: installation error
  • Microsoft Sync Framework Runtime v1.0 (x64): Installation skipped
  • Microsoft Chart Controls for Microsoft .NET Framework 3.5: Installation skipped
  • Microsoft Filter Pack 2.0: Installation skipped
  • Microsoft SQL Server 2008 Analysis Services ADOMD.NET: Installation skipped

I've tried Googling the error but found only one link, which didn't resolve my issue.

I located the log file (using: 'cd %temp%' then 'dir /od *.log'), and noticed that it contains the following text:

2011-07-11 01:53:43 - Beginning download of Microsoft "Geneva" Framework Runtime
2011-07-11 01:53:43 - http://download.microsoft.com/download/F/3/D/F3D66A7E-C974-4A60-B7A5-382A61EB7BC6/MicrosoftGenevaFramework.amd64.msi
2011-07-11 01:53:44 - Download of "Microsoft "Geneva" Framework Runtime" completed successfully
2011-07-11 01:53:44 - Installing Microsoft "Geneva" Framework Runtime
2011-07-11 01:53:44 - "C:\Windows\system32\msiexec.exe" /i "C:\Users\ADMINI~1\AppData\Local\Temp\IDF850F.tmp.msi" /quiet /norestart
2011-07-11 01:53:44 - Install process returned (0X654=1620)
2011-07-11 01:53:44 - [In HRESULT format] (0X80070654=-2147023276)
2011-07-11 01:53:44 - Last return code (0X654=1620)
2011-07-11 01:53:44 - Error: The tool was unable to install Microsoft "Geneva" Framework Runtime.
2011-07-11 01:53:44 - Last return code (0X654=1620)

Then I went to run the file "C:\Users\ADMINI~1\AppData\Local\Temp\IDF850F.tmp.msi" manually, and got a dialog saying:

This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package.

Then I noticed that when I put the Geneva download URL into my browser, I just get a 404.

So I guess Microsoft have taken the file off their servers.

Is there any way I can fix this, or get Geneva from somewhere else, or install Sharepoint 2010 without installing Geneva? And isn't anyone else having the same issue?

  • 1
    are you speaking about this link : blogs.technet.com/b/paulpaa/archive/2009/11/28/…? I can tell you also that url you can see in the log file to download Geneva is dead!
    – GillouX
    Commented Jul 11, 2011 at 9:27
  • Yup you're right, it's dead. So how are people installing Sharepoint? Is there anywhere else I can get the file? I've been Googling for it, but haven't found any download links for about 20 pages. Commented Jul 11, 2011 at 9:29
  • OK, I found a download link here: connect.microsoft.com/site642/Downloads/…. I'm going to try running it and see what happens. Commented Jul 11, 2011 at 9:37
  • Nope, no luck. Ran the installer to the end and it said it was successful. But when I ran the prerequisites installer again, I just got the same old message, and the log is also exactly the same. It ignores the fact that I've installed Geneva manually, and just keeps trying to download it from the broken URL. Commented Jul 11, 2011 at 9:43
  • 1
    so I guess you should install all the prerequisites manually and then launch the installation. blogs.msdn.com/b/mcsnoiwb/archive/2010/06/07/…
    – GillouX
    Commented Jul 11, 2011 at 9:44

2 Answers 2


It turns out that the Prerequisites installer was downloading a 0KB Geneva installation package, because the official Microsoft download URL is down (giving 404 errors).

I found a working link to the installer: http://download.microsoft.com/download/8/6/6/866E86E1-2264-4C80-836A-92F3F3A3B1AB/release/MicrosoftGenevaFramework.x64.msi.

So the steps were:

  1. Download the MSI file from the link above, to a local folder (e.g. C:\Prerequisites).

  2. Run the Prerequisites installer with the '/IDFX' switch (thanks for the blog link, @GillouX!):

    PrerequisiteInstaller.exe /IDFX:C:\Prerequisites\MicrosoftGenevaFrameworkSDK.x64.msi

    The Prerequisites installation now proceeds correctly.

  3. Then I can run the installer and it works! :)

  • Thank you, I see your article to help me solve the problem.
    – user12925
    Commented Nov 9, 2012 at 6:02

To fix just download thew new SPF2010 binary version 14.0.4730.1010

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.