0

Platform : share point 2013

When I was Changed my Admin user password and restart a server,get error after that

I checked all possibilities like

  • I changed my password from service account and logon information

  • This user is beside in local Pc Admin group

  • I was tried configure another admin user to timer service

  • Changed Admin user permission for APP ID HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppID{61738644-F196-11D0-9953-00C04FD919C1} for services and give admin to full access

  • -

Restart again share point server and IIS reset

all this possibles I have checked but My service still not started and error in event viewer "The SharePoint Timer Service service terminated unexpectedly" and that error comes up every two minute

  • Which account is running your sharepoint timer service? – Atish Dipongkor - MVP Oct 13 '15 at 11:37
  • administrator which is farm admin also @atish – Amit Koyani Oct 13 '15 at 11:54
  • did you change its password? – Atish Dipongkor - MVP Oct 13 '15 at 11:56
  • yes As mention in question..problem arise due to password changed...but I changed password in service> properties > logon but that can't help me any other trick..if any which save my life..@atish – Amit Koyani Oct 13 '15 at 11:57
  • @AtishDipongkor Any help in this topic..? – Amit Koyani Nov 6 '15 at 8:35
1

Saw this didn't have an answer marked and wanted to share what worked for me step by step to see if it will help others using SharePoint 2013.

  • On my database server opened up SMSS, then for each SharePoint database, made my service and web account db_datareader, db_datawriter, db_owner, SPDataAccess.
  • Ensured both service and web account had the following server roles in SQL: dbcreator, public, securityadmin.
  • On the server that Central Admin ran from gave both service and web account modify permissions to C:\ProgramData\Microsoft\SharePoint and subfolders.
  • Stopped the SharePoint Timer service, then in C:\ProgramData\Microsoft\SharePoint\Config, created a backup folder and moved all other folders into it. Did a copy of the last modified GUID folder to the backup folder. From there Deleted out all the xml files. Opened up cache.ini and replaced the number with 1
  • With SharePoint Timer service still stopped, found that SharePoint Administration and SharePoint Tracing services were using local system. Used my powershell script to change the log on as to spserv
  • PowerShell Script to Change the login

    $farm = Get-SPFarm $cacheService = $farm.Services | where {$_.Name -eq "SPTraceV4"} $accnt = Get-SPManagedAccount -Identity test\spserv $cacheService.ProcessIdentity.CurrentIdentityType = "SpecificUser" $cacheService.ProcessIdentity.ManagedAccount = $accnt $cacheService.ProcessIdentity.Update() $cacheService.ProcessIdentity.Deploy()
  • Double checked Local Group Policy to make sure service accounts had Log on as a service rights. https://technet.microsoft.com/en-us/library/cc794944(v=ws.10).aspx
  • I had forgot to start the service again, but need to mention this blunder as it was part of my steps. I blundered again and added my SharePoint Service account to the local admins group.
  • Started the SharePoint Service again this time with the warning that it was on the local admin group from SharePoint. Realizing my blunder from earlier removed it from the local admin group.
  • Started my SharePoint services back up. Waited 10 minutes and for once finally had 0 errors or warnings popping up in Events log!

I know this is an old thread but it described the exact issue I was having so I hope this shows up in the search for others to give a whirl on their end.

For me it's now been 24 hours after doing all these steps without any more failures in the event logs every 2 minutes about SharePoint Service. My backups and Search Service are also functioning now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.