0

We have been using SharePoint 2010 for various applications since last 3 years but since last two days users are unable to delete items from the list. The delete operation just does not return back and the list keep showing 'Deleting...' text.

I tried doing the same on a list as small as two columns and 4 items and the result is the same. Now, most of the time I am unable to even add or edit an item in the list. The request just does not return back. I am, however, able to view all lists and individual items in them.

What could be the issue?

Updated (After Gaurravs and Steven response): On checking the SharePoint database server, it was found that disk has enough space but RAM utilization is 15.8 GB of total 16 GB RAM and almost all of 5.8 GB was eaten up by SQL server service. After restarting the server it went down to 1.6 GB. We, then, Added and Updated a list item successfully with no difference in memory utilization. However, when we tried to delete a list item, it got stuck.

Looking at Resource Waits in SQL Server Activity Monitor, it was determined that an INSERT request was in SUSPENDED state. After this, we tried to Add and Edit an item but all got stuck with SUSPENDED state and memory consumption started to increase to the maximum limit. Then, we killed the suspended requests and tried adding and editing item and it went well. But again item deletion got stuck.

Futher more, the content DB data file size is 54 GB and log file size is 2 GB. Total records in AllUserData table are approx. 14200000.

More Details I have recreated the site through attaching content database files on a different SharePoint server and the issue is still the same. I ran "Test-SPContentDatabase" and SQL Server's DBCC CHECKDB with REPAIR_REBUILD on content database but of no use. Running SharePoint Products Configuration Wizard did not solve the problem either. It is discovered that delete works well on a new list and if an existing list is exported and then imported in a different site on the same server.

Appreciate if anyone can provide solution to this deletion issue. Thank You

  • Not so sure, but content database might be full. Can you verify from administrator if content database is full or not. Also if possible create a subsite or a list, it should also give you same issue. – Gaurravs Oct 12 '15 at 10:18
  • That's a really tricky one. Your investigation does point to a database issue. These are generally quite rare with SharePoint, but when I have seen them before it's generally either due to a corrupted DB index, or possibly a failed update which left the schema damaged. To fix a corrupted index, I would suggest you check the database maintenance guide at technet.microsoft.com/en-us/library/cc262731(v=office.14).aspx. If a failed update damaged the schema, running the SharePoint Products and Technologies Configuration Wizard can repair that, and I've also known it to fix mystery ... – Steven Mulkerrins Oct 13 '15 at 10:27
  • issues like this. Ideally I would suggest trying to take a backup of the DB and attaching it to another SP2010 instance to see can you reproduce the issue and then solve it there. But that would be time consuming. At a minimum I would recommend backing up everything before trying either suggestion above. – Steven Mulkerrins Oct 13 '15 at 10:28
  • Thank you Steven. I will try these out and update. I have taken site collection backup and put it on restore at a different server. If it behaves the same, then I will run Configuration Wizard there. – user47742 Oct 13 '15 at 17:49
0

Is it possible that you are out of disk space on your database server? I would also recommend checking event logs on your database server for any errors.

  • Please see the updated details in my original post. – user47742 Oct 12 '15 at 18:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.