0

I've got a app part that pulls data from a Blog and displays it through REST and Angular. The issue is that if the link in the body is from the same web app SharePoint makes it relative to the app.

The link should be: https://portal.com/sites/test

It comes back as https://app-4a7bc2b83f4b5a.spapp.com/sites/test

I get an error in IE stating "Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings" I changed my settings with no love, but I can't expect all users to do that anyways.

  • You pull data with Web Proxy? – eirikb Oct 13 '15 at 5:22
  • @eirikb It's an app part and pulls back a relative link through the iframe. Maybe I'm misunderstanding you though. – Christopher Oct 13 '15 at 17:44
  • Is the blog external? If internal can't you use REST, and if it is external either use normal AJAX (if it supports CORS or JSONP), or use web proxy – eirikb Oct 13 '15 at 17:47
  • That's my issue then probably. It is SharePoint Hosted. This is my first app part so I'm still learning. I wanted to use JSOM with Angular but I couldn't figure out how to connect them. – Christopher Oct 13 '15 at 17:49
  • Using JSOM should be straight forward. If you are reading from host web remember to use SP.AppContextSite. Also remember executeQueryAsync ends up in an asynchronous callback, which will be outside of the $digest loop, so then you either have to use $q to make ClientConext use promises or use $apply, or $timeout etc.. – eirikb Oct 13 '15 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.