I'm having trouble upgrading some content database to the June 2015 CU update. These databases were moved from on farm to another. They work, but when I try to run psconfig to update them I get the following error in the upgrade log.

Upgrade Timer job is exiting due to exception: System.NullReferenceException: Object reference not set to an instance of an object.

I have three databases that were moved giving the same error. It makes me think that there was an issue with the move itself.

We basically restored the databases from a backup to the new SQL server. I created a new web application for each and mounted the database to the web application.

Content wise, the databases work. I can see all the content and it functions properly. The only issue is trying to upgrade them.

migrated from stackoverflow.com Oct 9 '15 at 15:25

This question came from our site for professional and enthusiast programmers.

  • you've not given us enough information, can you post some logs to go with it? anything in the event viewer? – Nikerym Sep 16 '15 at 0:15
  • Have you tried -force option? Some times psconfig fails the first time and goes smoothly second. – Trike Sep 16 '15 at 6:45

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.