2

When I try to use the Find a file search functionality within a SharePoint List or Library it always returns

Your search returned no results. Some files might be hidden. Include these in your search.

I've tried the obvious in order resolve this issue, e.g. re-indexing the library, kicking off a new full crawl, checking content approval is set to no etc. All with no luck unfortunately.

I've investigated the issue further and spotted some interesting things which could be causing the problem but unsure what the actual fix is; e.g.

  • The web application is served to all users over https. (All users are internal users within our network - No external access)

  • The Alternative Access Mappings have two entries for the Intranet web application;

    Internal URL ZonePublic URL
    
    https web app url Default
    https web app url
    
    http web app url Default
    https web app url
    

When I reviewed the search crawl log I noticed all the URLs were indexed using http, not https.

This led me to doing some more testing with interesting results;

  • When I use Enterprise search everything seems to be working absolutely fine.

  • When I use OSSearch there are no results (even though there definitely should be)

I checked the search URL the OSSearch was using and noticed the U parameter for This Site scope started with https.

Because the crawl log indexed all files using http this was probably the issue. When I manually changed the U parameter to use http instead all the results were showing correctly.

I guess this somehow relates to why the search is not working in Document libraries and Lists too, but not entirely sure what the fix is.

I guess it somehow relates to either Alternative Access Mappings or the start addresses in the content source within search, however I have both http and https web app urls within the start addresses.

Please can someone give me some insight into this issue and a way I can fix it?

  • Are you searching based on a custom field? – Paul Strupeikis Oct 9 '15 at 9:14
  • Hi Robert, I'm not searching based on a particular field. It's just configured as the default settings. Cheers – The Dale Oct 9 '15 at 10:27
  • Ok, I'll ask another way - have you got any custom fields in the library? You say you're using "Find a File" but not searching based on a particular field. What do you type in the search box then? By the way, I am Paul, not Robert, but still - hello :) – Paul Strupeikis Oct 9 '15 at 14:30
  • Hi Paul, Sorry I got confused, turns out someone modified my post called Robert :D The document library has one custom content type associated to it which contains some custom site columns. However the content type does include the standard unmodified title field as the content type inherits from "Document". I'm not sure what field the search is using, presumably the Title field, how can I check? Cheers! – The Dale Oct 9 '15 at 15:11
1

Maybe I'm seeing this too late, I had the same problem with the Document Library search box and the solution was re-indexing the all the content at the Search Service Application ( Crawling/ Index Reset ) and running Full crawl. I can provide you full steps if its necessary.

  • Yes please provide the necessary steps to solve the problem. An incomplete answer will not help I am afraid. – Asad Refai Dec 25 '15 at 12:58
  • Ok, you will need to go to the Search Service Application where you can see Index Reset at the left side, right below Content Source Content source is the place you will need to visit after you do the index reset.So , after the index reset have finished do the Full Crawl ( Content Source / Select the Content Source and then Select full crawl) – JovicaS Dec 28 '15 at 19:44
  • @JovicaS , can you pls provide the full steps, you have performed on this issue? am also facing the same issue and search within doc libs, splists are not working. also i am having item level permissions, applied, folder level permissions applied, and doc lib level permissions too applied . – userAZLogicApps Jun 17 '17 at 18:08
0

Make sure you create Search Managed Properties for every custom field. I had that issue before in my custom library with a custom content type. When you search for a file in a library SharePoint basically does a keyword search and if a field doesn't have a managed property assigned then the document won't be returned. For example, let's say you have a content type with the following columns and a document with the following metadata:

Title:            "Document-1"
Name:             "Document-1.docx"
Country:          "UK"
Confidentiality:  "Top Secret"

Title and Name will have managed properties (as these are ootb fields) and doing a search with keyword Document-1 will return the file. On the other hand - doing a search with keywords UK or Top Secret won't return the file and will display a message:

Your search returned no results. Some files might be hidden. Include these in your search.

To add a managed property in SharePoint, you need to navigate to Central Administration -> Manage Service Applications -> Search Service Application -> Search Schema -> New Managed Property. Tick the following boxes: Searchable, Queryable, Retrievable and then Add a Mapping to a Crawled Property which would have a name like this: ows_CustomFieldName (CustomFieldName would be your custom field name from the document library).

After doing that, run a full crawl. Hopefully this will sort everything out.

0

Library Settings > Versioning Settings > Draft item security set to 'Only users who can edit items'.

0

Try using "Server Name Mapping" inside Search Administration and map "http" url to "https" url and then do the full crawl and search again.

0

A common result source configuration is to use Query variables to limit the results for example to the current site collection {SiteCollection.Url} or site {Site.Url}.

The library search features uses the default result source for its searches. This is not configurable.

If the default result source contains variables like the ones listed above, the search within the context of the library will fail and return no results. To achieve the goal of displaying results in a library search, remove the variables from the default result source. Note of course this will impact search results that use the default.

I don't have a comprehensive list of query variables that will cause problems (the SiteCollection- and Site- related ones will certainly). One approach you can use is to create a new result source, set it as the default, and add a variable and check to see if it still works in the library. Once you add one and it stops working, you now not to use that variable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.