2

I have a working Web App with FBA and a site containing a document library with office files. When using IE11, whenever I click on any of the files, I am prompted to login. After entering credentials, I get the following error:

Your organization's policies are preventing us from completing this action for you

When using chrome instead, the file is downloaded.

My questions are:

  1. Is there a way to set the default behavior of the library so that files are downloaded instead as happens in Chrome? Removing mimetype maybe?

  2. Is there a way to prevent that need of adding credentials? I've tried adding the following to the web.config file with no success

    <add verb="OPTIONS" allowed="false" />

    <add verb="PROPFIND" allowed="false" />

  3. How can I remove that organization's policies alert when using IE?


UPDATE

I removed the mime type for extension from the AllowedInlineDownloadedMimeTypes collection, and the user is now forced to download the file in IE. However, when trying to access any office file in Chrome, I get the External Protocol Request.

Any thoughts on how that can be disabled and the file downloaded?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.