0

I've been searching with my favorite search engine for a way to completely remove a failed search service application on a new SharePoint 2013 installation with no luck.

The error i'm getting repeatedly in my administrative logs are :

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Microsoft-SharePoint Products-SharePoint Foundation" Guid="{6FB7E0CD-52E7-47DD-997A-241563931FC2}" /> 
  <EventID>6398</EventID> 
  <Version>15</Version> 
  <Level>1</Level> 
  <Task>12</Task> 
  <Opcode>0</Opcode> 
  <Keywords>0x4000000000000000</Keywords> 
  <TimeCreated SystemTime="2015-10-05T02:12:56.137343800Z" /> 
  <EventRecordID>99999</EventRecordID> 
  <Correlation ActivityID="{2C7F349D-9E8B-5073-F440-A7BAB005D2EB}" /> 
  <Execution ProcessID="1808" ThreadID="1988" /> 
  <Channel>Application</Channel> 
  <Computer>PARVMASPROD001.itelios.local</Computer> 
  <Security UserID="S-1-5-21-1712695428-2925357708-3889103824-6311" /> 
  </System>
- <EventData>
  <Data Name="string0">Microsoft.Office.RecordsManagement.Preservation.PreservationJobDefinition</Data> 
  <Data Name="string1">faae89ce-fbc6-4457-bee6-f9af0fd6e714</Data> 
  <Data Name="string2">The search request was unable to connect to the Search Service.</Data> 
  </EventData>
  </Event>

I want to be able to remove it all and, if you can, point me to a resources that could provide me with a detailed step by step guide on how to set up a new search application for a production environment with less than 150 employees.

My farm's topology is as follows:

- Windows Server 2012R2 with SharePoint 2013 Central Administration & Application Server.

- Windows Server 2008R2 with SQL Server 2012 (where all the database are located.

- ADFS server 3.0.

- Office Web App Server 2013. 

Any help would be greatly appreciated.

Many thanks.

  • How did you try to remove it? – Christoffer Oct 6 '15 at 9:27
  • Hello @user19952 mostly by using the Remov-SPServiceApplication command from Management Shell running as administrator. I even tried the Central administration GUI hoping i might get a better results. – Asan Soileti Oct 6 '15 at 15:53
0

Use PowerShell and run the following commands. You can omit -RemoveData if you wish to keep the related DB.

$spapp = Get-SPServiceApplication -Name "<Search Service Application display name>"
Remove-SPServiceApplication $spapp -RemoveData

Also try restarting SharePoint Timer and SharePoint Administration Windows timer services.

Also try this:

$ssa = Get-SPEnterpriseSearchServiceApplication -id "<GUID of your Search>"
$ssa.Unprovision(1)
  • Hello @JussiPalo, i have followed your and it's been two hours since i've fired up the command as administrator in Management Shell. I have no output as a result, nothing it's like it's stuck. ULS logs are logging this line repeatedly : "Leaving Monitored Scope (Performance Inspect Scope). Execution Time=xxx, xxx" in a high priority level. Sharepoint Timer Service is still running and nothing in windows administrative event viewer shows at which point the command is blocked. – Asan Soileti Oct 6 '15 at 15:18
  • Those ULS row are not related to this. Updated my answer. – Jussi Palo Oct 7 '15 at 8:20
  • Thanks @jussipalo. i ran the second command you provided in your answer. It's been an hour, by the time i'm posting this reply, that the command has been running and looks stuck as the previous one. There are event ID 6398 critical, stating : "The Execute method of job definition Microsoft.Office.RecordsManagement.Preservation.PreservationJobDefinition (ID faae89ce-fbc6-4457-bee6-f9af0fd6e714) threw an exception. The search request was unable to connect to the Search Service." Is that any help to you/me ? – Asan Soileti Oct 7 '15 at 13:10
  • Did you restart the services as mentioned in my answer? – Jussi Palo Oct 8 '15 at 11:53
  • Yes, I did! Or maybe i have no done it the way you meant.? Do i need to restart the service before, while or after running the powershell command? In my case, i'd restarted the service before running the command – Asan Soileti Oct 9 '15 at 13:07
0

You can check the below :

  1. Clear SharePoint config cache, then restart timer service, then execute PowerShell command or through the CA try to remove search service application.

  2. Check the firewall and network connectivity between SQL server and your search service application server.

  3. Ask your SQL admin check the stability of SQL availability group.. if the SQL availability group does not work properly or not stable we will face this kind of issue and this AG group occurs when network is not up to the standard.

  4. Try restarting SQL service.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.