0

I have build an add-in for share-point and wrapped it with wix setup. In my application I have referenced for SharePoint.Client.dll.

But when ever I tried to open my application (installed in other machine) it throws me an error as could not load assembly.

enter image description here

NOTE: My application installed machine doesn't have SharePoint installed.

What is the problem? I have build the setup using wix. But everything works perfectly on development environment and there i have sharepoint installed.

5
  • how do add this dll into your solution? Oct 5, 2015 at 7:37
  • just by clicking 'Add Reference' in visual studio under .Net tab @AtishDipongkor
    – Dah Sra
    Oct 5, 2015 at 7:39
  • That means you give it from GAC. Add a folder in your solution ... paste the dll into it and add reference from this folder. Oct 5, 2015 at 7:43
  • @AtishDipongkor in developer environment uh..?
    – Dah Sra
    Oct 5, 2015 at 7:44
  • Yes ...... In your vs solution Oct 5, 2015 at 7:47

1 Answer 1

2

It works on your DEV, bacause you have SharePoint Client DLLs installed. If you want to install your solution on other server, you need to copy those dlls to your BIN folder.

In Solution Explorer right click referenced DLLs (Microsoft.SharePoint.Client.dll, Microsoft.SharePoint.Client.Runtime.dll) and select Properties. Set Copy Local to True.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.