0

I created a simple workflow in Sharepoint designer 2013, and there is only one step in it, which is to remove the permission of that item, I can see there is a "Remove List Item Permissions" in the action

enter image description here

But here's the problem: I am unable to remove permission in the "Shared with" people list, for example, this item is shared with these people:

enter image description here

What I want to do is to remove the edit permission in this list, instead of adding the group one by one in sharepoint designer, is there a way to select all groups and users?

enter image description here

I am unable to use "Everyone" since that item is not shared to "Everyone".

0

You can try using Replace instead of remove. This will remove all users and explicitly add the ones that you select.

Replace permissions

enter image description here

Hope that helps.

  • I get your idea, but the problem is: the item originally isn't shared to "everyone", which means not all the users are allowed to "read", if I apply your settings, then all the users will be able to "read" that item. What I want to do is just remove the "edit" permission of the shared persons or groups – User2012384 Oct 5 '15 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.