I've searched a lot before coming here to ask... Here is my situation, in SharePoint Online.

In a site with Content Organizer ON, I have created the library "Deposit Library", in which one users will upload documents (xlsx and pdf). I have created a workflow (SPD 2013) that starts when a document is created in the library: it adds some metadatas from a list. When its done, the workflow send the document to the DropOff library. Which is working fine.

When the document lands in the DropOff library, it stays there, until I manually goes in Document Properties, i do not change anything, I click on "Send" and then, the document is routed properly.

Why should I edit Document Properties? Is there a way for Content Organizer to launch routing rules automatically?

To help you understand, here is my settings:

Settings of Content Organizer:

  • Redirect users to dropoff = no
  • Send document to another site = no
  • Subfolders = no
  • Version control = add random characters
  • Conservation context = no

Rule I am working on:

  • Name = Agency
  • State = Active, priority 5
  • Content type = I have selected my custom content type, which inherit from Document content type, and only have simple text columns.
  • Conditions = IF Name StartsWith "Agency"
  • Destionation = "Agency Library"

Workflow details:

  1. Check if report exists in "Report List"
  2. Search Title, Nature, Category, Branch in Report List, and assign it to current item.
  3. Set Status of current item (custom column) to "To validate"
  4. Set a refecence date in current item (custom column)
  5. Copy and Delete current item to DropOff Library
  6. Extract/Archive document in DropOff Library (This is a test Ive made, to try to solve the problem...)

My custom content type is added to all libraries I am using. I really wish someone will find out whats going bad... Many thanks all !!

  • If you put a file in the drop off library directly with the right metadata, does it send as you would expect? Commented Sep 30, 2015 at 15:07
  • 1
    Yes, sorry I should have mention that. When I upload a file, with the metadatas, the file is routed as it should...
    – Dreller
    Commented Sep 30, 2015 at 15:12
  • If I upload a file, without metadatas, the file stays in the DropOff. Strange thing, because the only property that is required, is the "Name", which is always filled...
    – Dreller
    Commented Sep 30, 2015 at 15:14
  • I have checked the "DropOff CheckOut documents", and my document is archived, its not checked-out.
    – Dreller
    Commented Sep 30, 2015 at 15:22
  • I haven't used the content organizer like ever, but it appears to be operating in a similar pattern I've seen before. Workflow does something on item, copies it to a list with other workflows that fire on item creation, but the workflows never automatically trigger. This was always a system protection mechanism. I would open a support case through your Office 365 portal. Commented Sep 30, 2015 at 15:29

2 Answers 2


There is possibly a required column in destination list which is empty now. make all columns arbitary in destiantion List and then try the related job.


For anyone else coming across this, there is a Timer job called "Content Organizer Processing" which usually runs just once per day by default. This is why content in the drop off library will just sit there even though they match the rules to move off elsewhere. You can either run the timer job manually to clear the contents of the drop off Library, or set it to run, say every 15 minutes. The timer job is located on SharePoint Central Admin, Monitoring, Review job definitions.

Hope this helps :)

  • He referred to Sharepoint Online, no option to access the Central Admin jobs.
    – Yugo
    Commented Sep 19, 2018 at 16:31
  • Well, google brought me here and this helped me. Commented Feb 19, 2019 at 10:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.