0

I have a SharePoint 2013 site collection backup and i am trying to restore this back up on another SharePoint 2013 site collection. Both SharePoint sites are on the same domain. But when i try to restore the site collection from backup, i am getting an error as -

Restore-SPSite : <nativehr>0x80070003</nativehr><nativestack></nativestack>
At line:1 char:1
+ Restore-SPSite-Identity http://ksptestinst2:9999 -Path
"E:\SiteBackup\BackupSPS ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~~~
    + CategoryInfo          : InvalidData: (Microsoft.Share...dletRestoreSite:
   SPCmdletRestoreSite) [Restore-SPSite], DirectoryNotFoundException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletRestoreS
   ite

the command i use to restore site collection backup is -

Restore-SPSite -Identity http://ksptestinst2:9999 -Path "E:\SiteBackup\BackupSPSite.bak" -Force

i tried using

Restore-SPSite -Identity "http://ksptestinst2:9999/" -Path "E:\SiteBackup\BackupSPSite.bak" -Force -DatabaseServer KSQL2012SP\SQL
TESTDB -DatabaseName WSS_Content_KSPTESTINST2_9999

but both commands are giving same error.

Can anyone suggest how do we proceed?

  • My best bet is that there is a permission issue. What account are you using to restore the backup? – Christoffer Sep 28 '15 at 7:06
  • I am using a farm admin account to restore the backup. But the farm admin account for both servers are different. – Kalpesh Sep 28 '15 at 7:20
  • So there is 2 different farms? – Christoffer Sep 28 '15 at 8:30
  • Yes 2 different farms in same domain – Kalpesh Sep 28 '15 at 9:39
  • Try adding -Verbose flag and see if you get more information! – Vamsi K K Sep 29 '15 at 0:23
1

Both Farm should have same Patch level, upgrade the existing source DB (upgrade-spcontentdatabase) then take a fresh backup (Backup-SPSite -Identity http://dev:4646/sites/st -Path “\dev\Backup\st.bak” -force), upgrade the existing destination DB, then do a restore (Restore-SPSite -Identity http://dev:4646 -Path “\dev\Backup\st.bak” -Confirm:$false -force)

It will work

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.