0

I followed the instructions here to add a new property in advanced search, and to be able to search based on the custom column I made (which are metadata tags).

It worked well last week; but this week I started editing existing documents within the same library to add their metadata tags. When searching, however, the content with new tags don't appear - just the old ones which appeared last time. This is even when I added the same tags to other files in the library. For instance, file A with metadata tag (in the custom column) 'Documents' appear in the search results, but file B with the exact same tag, but added only now, does not appear.

I have tried full crawling 3 times, as well as re-mapping the managed property to the crawled property.

Please help!

0

I’ve found the problem! It turns out that the new files I added were automatically added as ‘checked out’. I just had to check them in and now they’re fully searchable! I only discovered the problem because I checked the same list through a colleague’s account (who also has full permission) and noticed that the files don’t appear in his account. I then started checking the properties and noticed the ‘Check In’ button.

It’s funny I didn’t notice that before, and I feel kinda dumb! hehe. Well now to check why they were uploaded as checked out, and prevent that from happening.

UPDATE: I realised that the reason my newly uploaded files were checked out is because I uploaded them using multiple uploads, while I have some properties which are required to be filled in for every file. To comply, SP checked them out by default. I couldn't check them in without adding the appropriate property content first. So I added the properties, then checked them in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.