3

I'm seeing some weird stuff going on with refining search results in SharePoint Online.

I've got a search results webpart set-up which returns items of a specific content type. Alongside it is a refiner web part which refines the results based on a managed metadata field set on those items. In this case, the refiner values are countries. There is no search box on the page as I just want it to show everything and let the users refine based on what they are looking for (requirement by the customer).

When refining, the following happens:

  • Selecting "Netherlands" returns 9 results.
  • Selecting "Belgium" returns 8 (different!) results.
  • Selecting both Netherlands and Belgium returns 10 results, the 8 Belgium ones and 2 from Netherlands.

So search now 'lost' 7 results tagged with Netherlands. Why?

With a different combination:

  • Selecting 'Algeria' returns 3 results.
  • Selecting 'Netherlands' and 'Algeria' returns 11 results, 8 tagged with Netherlands and the 3 from Algeria.

  • Selecting 'Belgium' and 'Algeria' returns 11 results, the correct ones!

I have trouble explaining (and fixing) this. In my opinion, selecting multiple refiners would result in an OR-type query, returning all results tagges with either of the values. By the way, all of the items are tagged with a single value, so they always belong to a single country. If this was an AND query, it should return nothing at all.

  • 2
    Could very well be a problem related to "TrimDuplicates". This functionality is activated by default and tries to remove duplicate items from your search results – Robert Lindgren Sep 21 '15 at 11:41
  • Would find that strange. These are pages with different URLs, different titles and different content. But still, could be. Do you know how to switch that off? – Jasper Sep 21 '15 at 11:45
  • You were spot on, it's trim duplicates. Turned it off by editing the query with the query builder, going to Settings and turning off duplicate trimming. Now everything is properly shown. If you put your comment in an answer I'll mark it :) – Jasper Sep 21 '15 at 11:50
  • @RobertLindgren Ridiculously experienced! That for most would of been a complete needle in a haystack! :) – MackieeE Sep 21 '15 at 12:24
  • 1
    Hehe, I've had the same issue myself, and did my search in the haystack ;) – Robert Lindgren Sep 21 '15 at 13:53
5

Could very well be a problem related to "TrimDuplicates". This functionality is activated by default and tries to remove duplicate items from your search results.

You can turn it off by editing the query with the query builder, going to Settings and turning off duplicate trimming, as per your comment :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.