0

We have a library that has worked perfectly for ever. Now when users try to add a new item (ribbon) or view an existing they get this message (server/username replaced with XXX)

The form template failed to load. (User: 0#.w|xxx, Form Name: Template, IP: , Request: http://xxx/sites/xxx/Lists/Work Requests/NotCompleted.aspx, Form ID: urn:schemas-microsoft-com:office:infopath:list:-AutoGen-2011-07-28T22:01:41:806Z, Type: InvalidCastException, Exception Message: Unable to cast COM object of type 'HTMLCHECKERLib.XMLPProcessorClass' to interface type 'HTMLCHECKERLib.IHTMLtoXHTML'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{A260B372-BC78-441B-8764-D0B83F4004F4}' failed due to the following error: Library not registered. (Exception from HRESULT: 0x8002801D (TYPE_E_LIBNOTREGISTERED)).)

I have opened the form in infopath designer and all checks out fine, I make a minor text change and save and publish to see if that helps but nothing. I have rebooted both the app and the web front end.

All other areas of sharepoint (inc browser based forms) are working fine. Help!

1

Found the answer so am returning to post it here for others who may need it. http://daniecsp.blogspot.co.nz/2013/12/sp2010-error-when-trying-to-load-info.html

My install is SharePoint 2013 so change OFFICE14 to 15 in the path to the dll. You also need to run the command from an elevated (run as administrator) command prompt for it to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.