3

I have a single user who is unable to access our SharePoint 2013 intranet site, everyone else can access it without issue. Regardless of the library or level of access granted to the user within SharePoint he runs into the same JavaScript errors (see screenshot).

Screenshot of JavaScript errors in the IE11 console

Things I have tried:

  • Site is in the trusted zone for intranet sites.
  • Cleared client cache.
  • Made the user library owner.
  • Made the user site owner.

My research seems to suggest that the problem is a permissions issue, I am a little baffled at that because the user is currently set as site owner with full control. Could this be a problem with the user's Active Directory account and the permissions at that level?

I am unsure how to proceed with further diagnostics. Can anyone shed any light on this?

Thanks

John

  • what's that with compatibility mode? – Gwny Sep 15 '15 at 14:05
  • @Gwny - IE opens all intranet sites in compatability mode by default, this occurs for all users. Related re: compatability mode – Burgi Sep 15 '15 at 14:09
  • 1
    The issue might be around configuration of the client machine's IE. Have you tried opening with any other browser in the affected machine. Also, you may try and debug using fiddler, that should give you a thorough idea if all the dependencies are properly getting loaded or not – Swayam Siddha Sep 15 '15 at 14:43
  • @SwayamSiddha it appears to work in FF, I'll have to get the service desk to install fiddler for me overnight. – Burgi Sep 15 '15 at 15:46
  • Thats good, good possibility that the issue is local to IE. Fiddler will help you drill down to the bottom – Swayam Siddha Sep 15 '15 at 18:46
6

The problem turned out to be overzealous Group Policies being applied to the Activity Directory OU that the user was in. Specifically it is these policies:

POLICY                                      CURRENT SETTING  SHOULD BE
Turn on Internet Explorer 7 Standards Mode  Enabled          Disabled
Use HTTP 1.1                                Disabled         Enabled
Use HTTP 1.1 through proxy connections      Disabled         Enabled
Microsoft Scriptlet Component               Disabled         Enabled

These links (1) (2) pointed me in the direction of an issue with the user's AD account last week but our infrastructure manager was insistent that the fault lay with SharePoint.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.