5

I have created a task list and added all necessary columns but when I navigate to the task list all views default to quick edit mode, like a datasheet, I want the list to default to the Standard view

I have created new views and set them specifically to standard view and NOT datasheet but every time I open the list it's in quick edit mode

The URL has ShowInGrid set to true:

/AllItems.aspx#InplviewHash44aadb47-cbf0-44bb-bc67-bb1d78406fda=CascDelWarnMessage%3D1-ShowInGrid%3DTrue

I am using SharePoint 2013 online in IE 11 and tested in Chrome

Edit: I have tried to create a new list (start from scratch) but every new task list that I create defaults to quick edit mode, is there a setting somewhere that would be causing this ?

  • Did you create the views programatically? Make sure you are using standard view to create the view. The Url hash automatically get added if it is a datasheet view. try t export the webpart and look at the XML, you must be having a property related to QuickEdit mode. change it and import the webpart again. If you are using XML to create View try tt=o compare the XML with Other OOTB views and make the changes – sekhar Sep 15 '15 at 6:54
  • I am using standard views, however I don't think it is a view issue because I have created a new task list and every new task list that I create defaults to quick edit mode – mlr Sep 16 '15 at 23:21
  • @mlr did you find a solution for this? – Arknev Nov 18 '15 at 18:18
  • @Arknev No I have not found a solution for this yet, i have noticed, as you said, that once the first item is in the list it reverts back to standard view, but I am still curious to find why empty tasks list are defaulting to quick edit – mlr Nov 25 '15 at 1:29
4

I have experienced this same issue. What I have found is that after you add the first item the list view will default to the Standard View NOT Quick Edit. So just add one item, navigate to the view (i.e. do not just refresh) and you should see that view no longer defaults to Quick Edit. Note that this occurs for the other views when no items are found. Such as the views for Completed and My Tasks.

3

I've had the problem many times and solved it quite easily. I don't know the root cause, but the solution is to create a new view.

  1. I only experienced this when creating a new list. Typically making a list from an Excel Export, and then adding a webpart of narrative content on top.

  2. I create a new view, and delete the old view.

  3. inserting an item into the list , or editing the list, does not solve anything. It's not a list problem. It's a view problem.

  • i don't see how it solved the problem for you : I have a custom Task list. I have created a view with the "Create a view" button in SP, set up my filters, and when I save, the empty view (because for the moment no item reaches the filters) is shown as Quick edit... – Gaelle Oct 26 '16 at 12:29
  • Don't know what to say. It works everytime for me. – Maxcot Oct 26 '16 at 16:48
  • i had the same issue after i create the list with a Excel-Export. Create new View... delete the old View... -> Problem solved :) Thx! – Edi G. in da House Jan 9 '17 at 14:27
1

Go to List Settings > Advanced Settings -> Quick Edit (switch to No)

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • The list itself (the cells) change to the Standard view but the heading still stays "Stop editing this list" and I cannot click the stop button (nothing happens) – mlr Sep 15 '15 at 2:26
  • as seen in this screenshot: gyazo.com/f77332f09d14d09eb432526efdfcf12f – mlr Sep 15 '15 at 2:26
  • 1
    Perfectly valid answer. Sometimes answers are just so simple. – Jussi Palo Sep 15 '15 at 8:21
  • What kind of style is your view? – JurajB Sep 16 '15 at 2:51
  • It is default style, but I don't think it is a view issue because I have created a new task list and every new task list that I create defaults to quick edit mode – mlr Sep 16 '15 at 23:18
0

The standard view is created using the default view. The trick is creating a default view that doesn't open in edit mode. I accomplished this by creating a view using the basic table style. For reference purposes, let's refer to it as "View A". After creating "View A", I switched it back to the default style. I now have a view that doesn't default to datasheet view. When I need to create a view on the task list that I do not wish to open in datasheet view, I change the default view to "View A" and select standard view when creating the list. An alternative to changing "View A" to default is selecting "View A" as the template for creating the new view. Thinking through it, the simplest thing to do maybe is create the view, switch the style to basic table, then switch back to the default view. Please vote up if you find this helpful.

0
  • Change the name of the AllItems view to a different name, say abc
  • Create a new standard view for the custom list
  • Rename the new view as All Items
  • Set the view as default view
  • Change the URL to AllItems.aspx.
0

I resolved that issue by going into: List Settings ==> Advanced Settings ==> Looked for 'Quick Edit' at the bottom of the page, and set its value to 'No'. It is enabled by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.