1

I have a situation in which the _layouts/UploadEX.aspx is displaying seemingly random characters as shown below. The Farm is SharePoint 2010 SP1.

I'm not sure where the strings in the image( 77e, 20 and 105.0) are coming from. Its only happening in the sites for one webApplication. The Site does not have a custom Upload Page associated with it.

Anyone ever seen this before and know how to stop it. Some of the strings are getting inserted into javascript code and are causing it to break.

It's happening enter image description here

1

This smells like a network issue.

Do you know if traffic to your SharePoint environment being routed through a load balancer? To confirm that the problem is stemming from the network, try updating your computer's host file so that requests for your SharePoint URL are routed directly to one of your SharePoint web servers; if the problem goes away, you'll know that the problem was coming from the network and not from the web server.

You should work with whatever team manages your network to understand why characters might be getting inserted into HTTP responses. Use a tool like Fiddler to trace the http requests and responses to identify the exact moments when the data gets garbled.

Edit: What fixed the problem was removing HTTP Compression and Caching profiles from the load balancer.

|improve this answer|||||
  • I am in a load balanced environment, and when I put an entry in my hosts file the issue went away. I took the entry out of my hosts and the problem reappeared. So I went onto the server and ran a wireshark,. Looking at the traffic sent out I am seeing the odd characters are being sent out by sharepoint, but ONLY if it comes thru the load balancer. Very confusing..... – russellg Sep 15 '15 at 14:36
  • @russellg what fixed this problem for us was disabling caching and http compression in the load balancer settings – Thriggle Sep 15 '15 at 20:25
  • thanks for the feedback triggle. I was thinking it was some custom code in my current environment. if you have seen this in your environment as well then I am looking in the wrong place. will need to try your suggestions above. thanks! – russellg Sep 16 '15 at 0:55
  • 1
    We removed the HTTP compression and caching profiles from the load balance and it resolved the issue.. Thankyou for your help! – russellg Sep 16 '15 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.