0

In my original list, there was a column for select/deselect. I changed the properties so it does not show up.

In the associated web parts page showing this list, the select/deselect button still shows up. How do I get rid

1

List views in web parts are not dynamic. If you set a view in a web part based on an existing view and then edit the view, the web part does not update as changes are made to the view, they become static based on how the view was defined at that time.

You must go into the web part and change the view to something different, Apply, switch back, and Apply, or click the link to Change this View and remove the unnecessary column to match your view.

This has been the behavior for a long while.

|improve this answer|||||
0

Edit the web part and set the view again.

|improve this answer|||||
  • I went to the web part ( far right side) and also tried to uncheck the asynchronous update. I then went to the original list, hit modify, and OK – Greg Sep 11 '15 at 18:41
  • Async update determines how the data is filled into the web part, it has nothing to do with updating the view. – Eric Alexander Sep 11 '15 at 18:43
  • If the list is showing correct, then is it how the web part is updating. – Greg Sep 11 '15 at 18:45
  • Greg, my understanding is that web part is working based on a view of the list. In such case, the web part stores its own version of the view which doesn't change when you change the original view. You can update the web part and set the view again and save the web part. – Vamsi K K Sep 11 '15 at 18:48
  • Just observed that Eric has provided step by step instructions for the solution i suggested. I come across this often in our projects. – Vamsi K K Sep 11 '15 at 18:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.