1

enter image description hereI am trying to create a workflow in SharePoint Designer 2013. I am doing a simple get the date and time when an item is created. But, every time I try to publish it I get the following error.

System.ArgumentOutOfRangeException: Specified argument was out of the range of valid values. Parameter name: id at Microsoft.SharePoint.SPTimeZoneCollection.GetTimeZoneInfoById(Int32 id) at Microsoft.SharePoint.WorkflowServices.SPWebWorkflowSecurityContext.CreateOrUpdateServiceGroup(SPWeb lookupWeb, SPAppPrincipal app) at Microsoft.SharePoint.WorkflowServices.SPWebWorkflowSecurityContext.b__3() at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass5.

Can anyone help guide me in troubleshooting this error? This is the first workflow to be created.

1

In order to fix this problem I rebuilt the site. This time I added my user to the admin group on the local machine. And reran the workflow register code with the -force to connect the workflow to the site.

0

I just did a workflow very similar to this. I'm not sure why it is throwing that particular error, but you can try my solution to see if it resolves it.

Another problem I see is that you want a time with the date, and the 'Today' argument only passes the date. The following statement doesn't use any workflow variables, and grabs both the date and time.

Set CurrentDate to Today 
then Set CurrentDate to Current Item:Modified

This assumes, of course, that CurrentDate is the field that you want the date stamp to appear in Sharepoint.

  • I edited my workflow to look the same as your's, and received the same error.I'm pretty sure that the problem isn't with the workflow. I think it is with how the SharePoint site is setup but i'm not sure what is wrong or how to fix it. – Tubbs Sep 11 '15 at 12:27
  • In Sharepoint Designer, when you go to create the workflow, there should be a little select box where you can select "Sharepoint 2013" or "Sharepoint 2010" workflow. Try it as a 2010 workflow. A while back, one of our guys got that error on our old server and this fixed it. This is more of a workaround, but we got it to work. – William Smead Sep 11 '15 at 13:12
  • Changing the workflow to 2010 did let the process complete. However, I need the 2013 workflows to work. – Tubbs Sep 11 '15 at 14:09
  • I'm not sure about that, then. After completing the workaround, I never investigated this matter further. I hope I still managed to help in some way! – William Smead Sep 11 '15 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.