0

We have a three server SharePoint 2013 farm, 2 WFEs 1 APP/CA server.

We were trying to get SQL reporting add on installed to one of the front ends. After the install it started behaving strangely, images were getting permissions issues, browsing to the root of a publishing site would prompt for an access request, etc. If we shut that server off it started working again.

We've tried reconfiguring the distributed cache... It seems to work for a few minutes and then starts failing again. Not sure where to look at this point.

  • Does your web application use Kerberos? – Mike Sep 9 '15 at 17:57
  • Yes, it does use kerberos – Snowburnt Sep 9 '15 at 18:16
1

Some things to check

  • Make sure the SPNs for Kerberos also apply to the server that does not work. You may not have enabled or set SPNs for the second server, and any web traffic that reaches that server will fail.

    setspn -s http/servername domain\webapplicationpoolaccount

    setspn -s http/servername.domain.com domain\webapplicationpoolaccount

  • You can try to disable the SharePoint Foundation web application service, and then reenable it, which will delete the IIS sites from that server and recreate them using the information in the Config database.

  • You should also make sure the LoopBack Check has been overridden or disabled. Look at this article here.

  • Make sure the administrators of the defunct server match that of the correct web server. Also, if the working server is in a GPO group that overrides the group policy of servers, make sure the defunct server is in that group.

  • Make sure your hosts file is not overriding DNS..

  • We've disabled kerberos and it's still having problems. LoopBack check hasn't been touched, administration is set properly and No hosts file. I have a sinking feeling it has to do with the SQL reporting services and/or a problem with the distributed cache. – Snowburnt Sep 9 '15 at 19:57
  • We just tried restarting the foundation web app service and it seems like it started working. If it still works in a couple hours, This looks to have fixed it! – Snowburnt Sep 10 '15 at 13:50
0

I had a similar issue some time ago. After long time of troubleshooting we reviewed the bindings in IIS. One Server just forgot it's configured bindings. After we fixed those, all errors disappeared.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.