0

The dev server is filled with errors 6398:

The Execute method of job definition Microsoft.Office.Server.Search.Administration.CustomDictionaryDeploymentJobDefinition (ID 339e26fd-56be-4f9e-b9bc-50c32d42b9ee) threw an exception. More information is included below.

Retrieving the COM class factory for component with CLSID {0FF1CE15-0005-0000-0000-000000000000} failed due to the following error: 80070422 The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. (Exception from HRESULT: 0x80070422).

And 6481 :

Application Server job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (f9677bce-935a-4d4f-97b4-8c7c32672676).

Reason: Retrieving the COM class factory for component with CLSID {0FF1CE15-0005-0000-0000-000000000000} failed due to the following error: 80070422 The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. (Exception from HRESULT: 0x80070422).

Technical Support Details: System.Runtime.InteropServices.COMException (0x80070422): Retrieving the COM class factory for component with CLSID {0FF1CE15-0005-0000-0000-000000000000} failed due to the following error: 80070422 The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. (Exception from HRESULT: 0x80070422). at Microsoft.Office.Server.Search.Administration.Gatherer.get_AdminObject() at Microsoft.Office.Server.Search.Administration.Gatherer.ProvisionGlobalProperties() at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Synchronize() at Microsoft.Office.Server.Administration.ApplicationServerJob.ProvisionLocalSharedServiceInstances(Boolean isAdministrationServiceJob)

Could anyone point me to the correct direction. We don't care for search services(yet)

0

Looks like it is permission problem on the Osearch in DCOM.

  • Open Start Menu > Administrative Tools > Component Services Tool
  • Drill Down and Expand DCOM Config
  • Navigate to the OSearch15,Right Click Properties
  • Select the Security Tab
  • Add the Network Service Account to Local and Activation Permissions
  • Add the Network Service Account to Access Permissions
  • Restart the Office SharePoint Server Search Service

I hope this will fix the problem.

  • It was OK - i.e. the network service was there. Yet the sharepoint server search 15 is disabled - we don't actually need it. – XristosK Sep 9 '15 at 7:38
  • If it is disabled n you don't need it then ignore these errors. – Waqas Sarwar MVP Sep 9 '15 at 10:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.