1

I am migrating my application from SharePoint 2010 to sharepoint 2013.

I have taken the backup of my 2010 site and then created the 2013 application in classic mode authentication.

Then I have deployed the solution from visual studio all the things are working except small changes.

until this all things were ok!!

But when I applied this changes in the qal server instead of deploying the changes from the visual studio i deployed the changes from the power shell command.After this when I tried to access the changes I was getting the error of the page not found for the application changes.

when I google this problem I found that my site is accesing the old layout page of 14 hive and for that I made the chagnes in the content database SPUIversion from the table ALLDocs.

according to this link http://sadomovalex.blogspot.in/2012/10/problems-with-upgrading-claims-based.html

then changes were working fine.

Now my admin team is not allowing me to make changes in the content database.

I searched but I didnt get any solution for this problem

Guys please help me out

Thanks and Regards,

Swapnil

1 Answer 1

3

Deploy the solution in compatibility mode and it will work fine, below is the command:

Install-SPSolution -Identity contoso_solution.wsp -GACDeployment -CompatibilityLevel {14,15} 

Source

Also you can perform UserRole migration, it also helps, you check out this msdn link.

1
  • 1
    We have done this before not worked I redeployed the changes and its working correctly now
    – Swapnil
    Sep 9, 2015 at 4:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.