I've reinstalled SharePoint with least privilege accounts, and use a separate account for all non-central-admin web apps. This separate domain account is in the WSS_WPG group, and seems otherwise to be working just fine. The issue, however, is that the ULS logs get no entries from the webapps running under this user.

I've tried resetting the logging service, made sure the tracing service runs as localsystem, reset iis about 10 times and tried just about everything else I can think of.

  • 1
    Apparently it's necessary to put custom app pool users in the "Performance Log Users" group on the server in question. After doing so, and resetting iis, logging should work. – BonesTune Jul 5 '11 at 13:10
  • 1
    If that was the answer, you should move it to the answer block and mark it as such. – Jesus Shelby Jul 5 '11 at 14:05
  • Putting the user in the "Performance Log Users"-Group it worked nicely. – Daniel Oct 24 '12 at 8:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.