0

Im connect custom attributes in profile service AD item (homePhone, CellPhone), after sync they are shown in profiles (private sites). Then Im add this properties in display templates of search results and add it in type of results - nothing in search results. I doing some tests, my parameters in display templates gets null. Why its working in private sites, but in search results not?

In search result, its seems like:

Peter Petigru

Work phone: 1000

Mobile Phone:

Home Phone:

All 3 attributes in 1 display template, configuring correctly. How you can see work phone correctly shown, because hes default in profile service.

0

Did you create Managed Properties for the Custom User Profile properties? Search and Display Templates use Managed Properties on the context of the current item.

I have a complete walk through of the steps if you have never done this before: http://www.ableblue.com/blog/archive/2013/06/05/introduction-to-sharepoint-2013-display-templates/

  • Display template how in your instruction. >Did you create Managed Properties for the Custom User Profile properties? If you mean sync settings in profile service - thats ok. Because private sites gets custom properties information. >Search and Display Templates use Managed Properties on the context of the current item. What you mean? in search service -> Search Schema? Thats, I think ok puu.sh/jZylJ/4025713cec.png – Pavel Kolbasov Sep 4 '15 at 12:19
  • Yes, you always have to create your own Managed Properties in the Search SSA for User Profile Properties. – Matthew McDermott Sep 4 '15 at 22:15
  • But thats not help... in search still blank – Pavel Kolbasov Sep 5 '15 at 7:19
  • @PavelKolbasov did you work through the whole post? Did you create the managed properties in the SSA? (It does not work in the Site or Site Collection with User Profile Properties.) Did you perform a full crawl after creating the Managed Properties? This always works. – Matthew McDermott Sep 6 '15 at 11:10
0

Im resolve my problem. Steps: 1. Delete search index 2. in Search Schema delete default lines with needed parameters 3. Create our own lines with needed parameters 4. Run full crawl

All works. And i still dont understand why thats not work with default lines, they was correct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.