My old solution has been running in my intranet farm for a long time. The solution contains a feature which deploys a webpart. The webpart shows the users of a group, together with information from their user profiles.

I've done some pretty big changes to the solution, removing the old Visual WP and creating a new WP. I've removed the old WP from the feature, deleted it and added the new. The Feature has the same GUID.

I've tested the solution in a local, dev and QA env, all working out fine. When I tried to deploy to my prod. env., something went wrong. After deploying the solution, users are asked for credentials (but are not allowed to log in) in the whole web. app. I had to retract the solution again, and it seems like that fixed it.

I then tried to delete the WP on all pages where it was added. I deployed the solution, activated the feature without problems. When I added the WP to a page, the same thing happened again. Even farm accounts are not allowed to log in, so I don't think it's a permission issue either.

The way I'm redeploying is by retracting, installing the old solution, and then adding and installing the new solution. I'm not specifying any Upgrade actions - should I?

  • Is there any information in the ULS log that might help to diagnose this issue?
    – Steve P
    Jul 3, 2011 at 9:41
  • I can't find any spesific related to this, but I might be missing something.
    – tarjeieo
    Jul 4, 2011 at 9:03

2 Answers 2


In my experience there are a few reasons why these popups occur:-

  • the code is throwing an UnAuthorisedAccessException but your code is not configured to catch the exception. When creating your SPSite object there is a property that you need to configure called CatchAccessDeniedException, set this to false so that you can catch these errors in your code and take appropriate action.

Now the issue is where in the code does this exception happen?

Using your web part description, the place where this is could be happening is when accessing the SharePoint Groups. I have seen issues where the Groups settings are configured so that only Group Members can view the members of the group. Check your groups on the site that will be enumerated by your web part and ensure that Everyone is able to see the members for those groups.

If that is not solving the problem then I would use Trace statements within your code and add them to the web part, build a debug version of the web part and use debug viewer on the server to help find out where the code is throwing the access denied message.

Regards Simon


Seems that the problem was the user profile images. I posted a new thread here: Permission problems (access denied) when listing all user profile images

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.