2

I have configured Workflow Manager 1.0 for SharePoint 2013. The backed service is not running. keeps on trying to run but fails, please check the error logs shown below:

Log 1:

The Workflow Manager Backend service terminated unexpectedly.  It has done this 1158 time(s).  The following corrective action will be taken in 30000 milliseconds: Restart the service.

Log 2:

The Service Control Manager tried to take a corrective action (Restart the service) after the unexpected termination of the Workflow Manager Backend service, but this action failed with the following error: 
An instance of the service is already running.

Log 3:

Application: Microsoft.Workflow.ServiceHost.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: Microsoft.Workflow.Common.FatalException
Stack:
   at Microsoft.Workflow.Common.Fx+<>c__DisplayClass2.<FailFast>b__0()
   at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
   at System.Threading.ThreadHelper.ThreadStart()

Log 4:

Faulting application name: Microsoft.Workflow.ServiceHost.exe, version: 1.0.20922.0, time stamp: 0x505e1b24
Faulting module name: KERNELBASE.dll, version: 6.2.9200.16384, time stamp: 0x5010ab2d
Exception code: 0xe0434352
Fault offset: 0x00000000000189cc
Faulting process id: 0x57d0
Faulting application start time: 0x01d0e5447982390a
Faulting application path: C:\Program Files\Workflow Manager\1.0\Workflow\Artifacts\Microsoft.Workflow.ServiceHost.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: bfe9ff19-5137-11e5-942b-0010c6b0d251
Faulting package full name: 
Faulting package-relative application ID:

What Should I Check for. Suggestions please!!

2

When I have problems with services not being able to start, I can often resolve them by re-entering the password for the account that that service runs as.

Go to Services on your server > right-click the problem service > Properties > in one of the tabs you'll find the user account and password that the service runs as > re-enter the password > OK > try starting the service.

If that doesn't work, I'm sure reinstalling Workflow Manager will resolve the issue. See here for answers to a similar problem.

  • I tried this yesterday. It did not Help.. After 10 secs the service stops again. I have already uninstalled and reinstalled around 3 times now. Same story :( – Muhammedh Sep 2 '15 at 8:30
  • When you reinstalled did you install Workflow Manager and Service Bus and then install the CUs? – Submits Sep 2 '15 at 8:40
  • 1
    Actually I installed WF Manager and Service Bus.. Tested and it dint work So I installed the CUs. Should i wipe out everything and install again? – Muhammedh Sep 2 '15 at 8:56
  • 1
    Yes definitely. Check the link in my answer and you will see in what order you should uninstall each item, delete the workflow related databases from SQL Server, then in what order you should reinstall each item. Install with Web Platform Installer. In Web Platform Installer you might also find details on which versions to install in which order. Otherwise, just install WF Manager and Service Bus, then CU1 for each, then CU2 for each (if available). – Submits Sep 2 '15 at 9:05
  • I'm on it now.. Will update after it's done. – Muhammedh Sep 2 '15 at 9:14
0

enter image description herePlease check step by step from my technical blog: http://sharepointtaskmaster.blogspot.my/2013/04/workflow-manager-farm-for-sharepoint.html

  • Please quote the main aspects of you article as otherwise this answer might get removed. – Paul Strupeikis Jan 23 '17 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.