2

I have an issue with our Travel Tool based on SharePoint 2013. This tool consists of different Content Types - all in their specific lists (travel requests, train rides, flights, etc.). There are two main groups which are using this tool: Employees (contribute) and admin staff (full control). On the homepage.aspx we have a ScriptEditorWebpart with a custom HomePageNewItem button and a ListView of the travel requests. When the user clicks on the custom button, a new ListItem is created via REST API and the EditForm.aspx of the currently created ListItem is displayed.

What is the problem?

This works just fine for the admin staff (full control). When employees try to create a ListItem, the following error message occurs: HRESULT: 0x80131904 (returning from the REST API). The same happens, when employees visit some of the lists. The ListView isn’t displayed, but there is the same error message.

Some additional information:

  • The SQL database has enough storage on all partitions
  • When an employee uses the standard “New Item” Button, everything works just fine (except of the ListView)
  • When an employee is moved to the admin staff group, everything works just fine
  • All lists have correct permissions set
  • This worked one week before and there were no changes in the code, only some customizations of sites e.g. homepage.aspx)

Additional hints:

Could it has something to do with the Website Definition?

  • 1
    If Employees can create items the 'normal' SharePoint way, the problem must be in the script that creates the new item. – Danny '365CSI' Engelman Aug 31 '15 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.