0

I'm trying to configure managed properties through PowerShell but there's one particular parameter that I can't figure out. I want to make a certain property refinable but none of the commands listed on TechNet seem to correspond to that. I tried just using a -Refinable $true param but PS is telling me that doesn't exist.

Edit: I can see the property itself with $Property | Get-Member Refinable but can't for the life of me figure out how to change it! My C# logic of trying $Property.Properties["Refinable"] = $true doesn't seem to work because the .Properties method is returning null.

1

The problem was in my variable name. You can't call something "$Property" if it actually has a properties bag! Renamed it to "$Managed" and it worked just fine. Silly PowerShell.

For reference, once I changed the variable name I was able to set the property like this (this exact method did not work while using the old variable name):

$Managed.Refinable = $true
$Managed.Update()
  • Do you have to run a full crawl afterwards for this to take effect, or does it become refinable immediately (assuming the prop in question has already been added to the index)? – Chris Odegard Dec 4 '18 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.