0

I am trying to set up a new dev machine.

When I run the wizard to configure SharePoint Foundation 2010 I get the error shown in the title.

From searching the net I see that one proposed solution is to uninstall VS 2010, reinstall Windows Activation Services and reinstall IIS.

Does anyone know if this works or of a better way to get the install working?

3 Answers 3

1

That sounds more like your web.config is b0rked. Have you tried simply reinstalling SharePoint Foundation?

1
  • Yes, I have also tried deleting the sharepoint administration site that it is refering to. Commented Jun 30, 2011 at 13:55
2

I had this error message when I tried to run a Silverlight application as a sub directory of my SharePoint application in IIS with the Silverlight application running under .NET 4.0. Try checking that all the sub directories of your SharePoint application are still running on .NET 2.0.

2

I had this same issue when running the SharePoint 2010 PSConfigUI.exe and was not too keen to go adjusting the web.config files right away.

I went into INETMGR.exe (IIS manager) and changed the .NET framework for all the SharePoint related app pools from 4.0 to 2.0. You may also want to restart IIS (IISRESET from an administration command prompt (right click cmd and select Run As Administrator)) if needed.

At this point I was able to finish installing SharePoint 2010.

You may still have the line which can be deleted if this issue is still reported by your browser when connecting to the SharePoint site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.