1

I have removed application/pdf from $webapp.AllowedInlineDownloadedMimeTypes and updated. I have checked if the server is not running in the Permissive mode - it is not. What else can I do? All the PDF documents are opened in the browser. I think they should not, after I did what I did. Any Ideas, please? I just want it to open in the Adobe Acrobat, or Reader... for start.

UPDATE: I have added <Mapping Key="pdf" Value="icpdf.png" OpenControl="AdobeAcrobat.OpenDocuments"/> to docicon.xml, as well.

UPDATE: In the SarePoint shell I typed: Get-SPWOPIBinding –Application "WordPDF" | Remove-SPWOPIBinding -Confirm:$false and now it is not using a browser to open. Now the problem is that it is asking me to save the file with no option to open it.

  • did you perform an iisreset after you made those changes? – Mike Aug 26 '15 at 13:30
  • I have rebooted entire Windows Server 2012, just in case. It is a test setup, so I could do it without any issues. I have an update! I will edit my question in a second... – vt100 Aug 26 '15 at 13:39
  • Isn't this -also- depending on the client configuration? Do you reproduce on different client OS/browser/PDF readers? – Evariste Aug 26 '15 at 13:59
  • Have you tried enabling open in client application feature for the site collection? – Akhoy Aug 26 '15 at 14:33
1

Oddly enough if you are still having this issue and have Adobe Acrobat and Reader installed and are using IE do the following.

  1. IE Options --> Select Manage Add-ons
  2. Select from Show: Run without permission
  3. Make sure to Disable "Adobe PDF Reader"

This will allow for the PDF to open in the application instead of in-browser.

enter image description here

enter image description here

  • 1
    FYI for anyone needing to save changes...disabling "Adobe PDF Reader" did in fact allow the PDF to open externally in Acrobat Pro, but after changing the PDF and saving, the changes never made it back into SharePoint. To get the changes to "stick", I had to do a "Save As" on the document and re-point the Save As dialog to the SharePoint document library where I opened the document from. This method did allow me to save the changes I made back to SharePoint. – RSW Dec 6 '16 at 21:27
0

If you are using IIS7 or later, I think you need to disable the webDAVModule after what you already did:

  1. Choose Start > Administrative Tools > IIS Manager.
  2. In the left pane, expand the tree, and navigate to your site.
  3. In the center pane, double-click Modules. In the Modules window, If WebDAVModule is present, remove it.
  4. Restart IIS

This is because SharePoint has its own WebDAV implementation. If the WebDAVModule is running, requests are routed there rather than the SharePoint WebDAV component. Disable the WebDAVModule to route the requests to the WebDAV component.

  • Sorry, Xavi... There is no WebDAV. Only two starting with 'W' are: WindowsAuthentication and WindowsAuthenticationModule. Thanks anyway... +1, since it can help somebody else. (oops, not enough reputation to give it, sorry) – vt100 Aug 26 '15 at 14:19
  • No problem vt100, tried to help :) – Xavi Aug 26 '15 at 14:37
0

if you are using office web app server 2013 or 2016 use below command to exclude pdf extension from rendering in Office web app

 Get-SPWOPIBinding –Application "WordPDF" | Remove-SPWOPIBinding -Confirm:$false

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.