0

I'm trying to configure an environment for apps for SharePoint (SharePoint 2013), Following MS official docs when I try to Run the following PS

add-pssnapin "Microsoft.Sharepoint.Powershell"
$AppPool = New-SPServiceApplicationPool -Name CampariSettingsServiceAppPool -Account (Get-SPManagedAccount DOMain\user)
$App = New-SPSubscriptionSettingsServiceApplication -ApplicationPool $appPool -Name CampariSettingsServiceApps -DatabaseName SettingsServiceDB
$proxy = New-SPSubscriptionSettingsServiceApplicationProxy -ServiceApplication $App
Get-SPServiceInstance | where{$_.TypeName -eq "Microsoft SharePoint Foundation Subscription Settings Service"} | Start-SPServiceInstance` 

I get tthe error:

New-SPSubscriptionSettingsServiceApplicationProxy : A SPSubscriptionSettingsServiceApplicationProxy with id '718596e0-df41-47e7-9117-1659b32fccf2' already exists. Only one can exist per farm. At line:4 char:10 + $proxy = New-SPSubscriptionSettingsServiceApplicationProxy -ServiceApplication $ ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : ResourceExists: (SPSubscriptionS...pplicationProxy:SPSubscriptionS...pplicationProxy) [New-SPSubscript...pplicationProxy], InvalidOperation Exception + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletNewSubscriptionSettingsServiceApplicationProxy WARNING: 'Microsoft SharePoint Foundation Subscription Settings Service' is already started on server 'GRISPWL0'

  • Looks like you already have one. Did you install the farm manually or automatically? – Christoffer Aug 26 '15 at 10:32
  • Do you mean, configuration wizard? – hello B Aug 26 '15 at 10:34
  • 1
    Yeah, when you set up SharePoint you can choose to let the wizard do it for you or if you wanna set up all services by yourself. If you choose automatic installation, i'm very sure that the subscription setting service is included. You can find out what services are installed by running "get-spserviceapplication | select displayname, typename" in PowerShell. – Christoffer Aug 26 '15 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.