1

I am fairly new to the SharePoint 2013 product, so please be gentle. My company has recently installed and setup SharePoint 2013 (no users yet) and we are trying to get workflows to work. However, we keep having issues with the 2013 workflows. The most recent of which results in the following error:

RequestorId: 895b6ad6-83b4-4156-0000-000000000000. 

Details: An unhandled exception occurred during the execution of the workflow instance. 

Exception details: 
System.ArgumentNullException: Value cannot be null. 
Parameter name: 
Input at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at 

System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at
System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

The workflow that I am creating is very simple. It consists of two document libraries: Documents and Template. I have a .docx file in the template library that I would like to move to the documents library. I execute the following workflow:

Log 'Starting to Copy' to the workflow history list

then Copy document in 'Current Item' to 'Documents'

then Log 'Finished Copy' to the workflow history list

Transition to Stage:
Go to 'End of Workflow'

This is as basic as it gets. We have SharePoint 2013 with SP 1 installed. We have the Workflow Manager 1.0 with the following updates installed: enter image description here

and I have tried the following:

  • Restart SharePoint server.

  • Created the exact same workflow as above in 2010 workflow. This worked flawlessly. The 2010 workflows executes without a problem.

  • Tried different document types and different subsites. Not fixed.

One more thing to add. I've had this code working before, the thing is we made a lot of changes and patch updates. I am guessing that maybe that it is one of the workflow manager updates that broke it? Is that a possibility? Anyone have any thoughts on what I can do to fix this? Also, is there a way I can find out the correlation ID? I can't find anything in the logs.

Thanks!

0

I have resolved the issue that I was having that was similar to this. I have a doc library that uses an InfoPath form template. I noticed that the file name that InfoPath created is fairly long, e.g. i.o.abc_domain_jblogs-2015-1-02T10_34.xml not to mention the URL for the doc lib itself. So I went into the web.config file and increased both the maxRequestLength and maxUrlLength, reset iss, and restarted the WF and voila… the doc moved over to the approved lib.

The error message that SP gave was pretty useless in looking into the issue. However, after I reviewed the server log, I did find an error that was helpful: Application error when access /deptdev/is/vti/bin/client.svc, Error = The length of the URL for this request exceeds the configured maxUrlLength value.

Perhaps this answer will apply to you as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.