1

I am trying to add a Content Search Webpart in my office 365 Site Collection Page . I was able to configure the query and was able to see the results in the query builder Window. Now when i Apply the changes to the web part. There are no results getting Displayed . On Debugging the page, i found the error "Search-Driven content (592CCB4A-9304-49AB-AAB1-66638198BB58) feature needs to be activated to use this Web Part."

My site is a Team site template with Publishing features enabled. Another thing is , I have another tenant where everything related to this works.

Things done :

  • Enable Search Server Web Parts and Templates
  • Enable Search Engine Sitemap
  • Tried Enabling Cross site publishing feature, but it again threw error saying it needs the search driven content feature activated.

Any Help would be highly appreciated ?

  • Try enabling that feature using Powershell. Refer: kbasrai.com/b/2013/10/08/… – Akhoy Aug 20 '15 at 5:32
  • I have enabled using Powershell but still wouldnt – Arvi Aug 20 '15 at 7:17
2

The issue is because the Subscription Plan in the Tenant site does not Support Content Search Web Parts. May be the error should have been “ Your Subscription plan cannot activate the feature.” :)

Learning : Check the Service Description of the SharePoint o365 Plans before troubleshooting .

  • Is (SPOnline) Search accessible through the API? – Danny '365CSI' Engelman Aug 20 '15 at 10:00
  • All the Plans do support Search Rest API . – Arvi Aug 20 '15 at 13:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.